問題

ArcMap または ArcGIS Pro でラスター データセットを追加できない

Last Published: March 26, 2021

説明

ラスター データ、デジタル標高モデル (DEM)、Esri GRID などのラスター データセットを ArcMap または ArcGIS Pro に追加するときに、次のメッセージがそれぞれ返されます。

ArcMap の場合

ArcMap では、エラー メッセージに続いて警告メッセージが表示されます。

エラー: 無効なラスター データセットです。 ラスター レイヤーの作成に失敗しました。
ArcMap にラスター データセットを追加しようとして失敗し、次のエラー メッセージが返されます。
警告: 指定したデータ オブジェクトをマップに追加できませんでした。 ラスター データセットを開けませんでした: <ファイル パス>: 権限は拒否されました
ArcMap でのラスター データセットの追加が失敗すると、エラーメッセージに続いて警告メッセージが表示されます。

ArcGIS Pro で

エラー: データを追加できませんでした。データ タイプがサポートされていません。 <ファイル>
ArcGIS Pro にラスター データセットを追加しようとして失敗し、次のエラー メッセージが返されます。

原因

この問題の既知の原因として、次のようなものがあります。

  • ラスター データセットがローカル ディスク (C:) に保存されていない。
  • ラスター データセットのファイル パスまたはファイル名が、ArcGIS のファイル名制限に従っていない。 詳細については、「ArcMap: 名前の制限」をご参照ください。

解決策または対処法

原因に従って、次の選択肢からいずれかひとつを使用し、この問題を解決してください。

ラスター データセットをローカル ディスク (C:) に保存する

ArcMap の場合

  1. 目的のラスター データセットをローカル ディスク (C:) 内のフォルダーに移動または保存します。
  2. ArcMap を起動します。
  3. [カタログ] ウィンドウで [フォルダー接続] を右クリックして、[フォルダーに接続] を選択します。
[カタログ] ウィンドウの [フォルダー接続] を右クリックして [フォルダーに接続] をクリックし、ワークスペース フォルダーの GIS 情報に接続し、作業を行えます。
  1. [フォルダーに接続] ウィンドウで、ステップ 1 のラスター データセットの新しいフォルダーの場所を選択し、[OK] をクリックします。

ArcGIS Pro で

  1. 目的のラスター データセットをローカル ディスク (C:) 内のフォルダーに移動または保存します。
  2. ArcGIS Pro を起動します。
  3. [カタログ] ウィンドウで、「ArcGIS Pro: フォルダーのプロジェクトへの追加」のステップ 1 に記載のいずれかのオプションを使用して、フォルダー接続を追加します。
プロジェクトの完成とアーカイブに必要なアイテムが格納されているローカル コンピューターまたはネットワーク コンピューター上のフォルダーに接続します。
注意: あるいは、Windows ファイル エクスプローラーからフォルダーをドラッグし、ArcGIS Pro の [カタログ] ウィンドウにドロップする方法もあります。 ArcGIS Pro の [コンテンツ] ウィンドウにフォルダーをドラッグ アンド ドロップし、フォルダー接続を確立します。
  1. [フォルダー接続の追加] ウィンドウで、ステップ 1 のラスター データセットの新しいフォルダーの場所を選択し、[OK] をクリックします。

ラスター データセットのファイル パスまたはファイル名が名前の制限に従っていることを確認する

ラスター データセットのファイル パスまたはファイル名から、すべてのスペースおよび特殊文字を削除します。 詳細については、「ArcMap: 名前の制限」をご参照ください。

記事 ID: 000020632

新しい問題や一般的な問題に対する通知とソリューションの受け取り

新しい AI チャットボットから、要約された回答とビデオソリューションを入手してください。

Esri Support アプリのダウンロード

ArcGIS エキスパートのサポートを受ける

テクニカル サポートへのお問い合わせ

Esri Support アプリのダウンロード

ダウンロード オプションに移動