ERREUR

Le portail a été initialisé et configuré, mais est actuellement inaccessible. La base de données du portail interne ne semble pas fonctionner ou accepter les connexions

Last Published: October 1, 2021

Message d’erreur

Accès impossible à la page d’accueil du portail et affichage du message d’erreur grave suivant dans les journaux du portail :

Erreur : Le portail a été initialisé et configuré, mais est actuellement inaccessible. La base de données du portail interne ne semble pas fonctionner ou accepter les connexions.

Ce message d’erreur apparaît dans les situations suivantes :

  • Mise à niveau vers une version plus récente de Portal for ArcGIS.
  • Redémarrage du service du portail.
  • Le serveur a été arrêté de manière non conforme. Par exemple, en cas de panne de courant.
  • Après l’échec de la publication du contenu sur Portal for ArcGIS.

Cause

  • Portal for ArcGIS ne peut pas accéder au data store car ce dernier est en mode de lecture seule par manque d’espace disque.
  • Quantité insuffisante de mémoire RAM sur la machine du portail. Pour plus d’informations, reportez-vous à Portal for ArcGIS : configuration matérielle.
  • Le compte de service spécifié lors de la configuration de Portal for ArcGIS est différent de celui qui est spécifié lors de la configuration d’ArcGIS Server et d’ArcGIS Data Store. Tous les composants d’ArcGIS Enterprise doivent utiliser les mêmes comptes de service.
  • Portal for ArcGIS a mal été configuré ou fédéré.

Solution ou alternative

Selon l’origine du problème, utilisez l’une des solutions suivantes pour y remédier.

S’assurer que l’espace disque et la quantité de mémoire RAM sur la machine du portail sont suffisants

  1. Augmentez l’espace disque de la machine ArcGIS Data Store. Pour plus d’informations, reportez-vous à la section ArcGIS Enterprise : Espace disque requis.
  2. Modifiez le paramètre du répertoire de données relationnelles du mode lecture seule en lecture-écriture. Reportez-vous à la solution indiquée dans l’article Error: Failed to create new feature(s). General Function Failure [database error has occured.] (Échec de la création d’entités. Erreur générale de fonction [erreur de base de données]) pour plus d’informations.

Configurer Portal for ArcGIS de sorte qu’il utilise le même compte de service qu’ArcGIS Server et ArcGIS Data Store

Portal for ArcGIS, ArcGIS Server et ArcGIS Data Store peuvent être configurés de manière à utiliser un compte de domaine, un compte local ou un compte de service administré de groupe (gMSA). Le même type de compte de service doit être utilisé pour tous les composants d’ArcGIS Enterprise.

Pour changer le compte de service utilisé dans Portal for ArcGIS, reportez-vous à ArcGIS Enterprise : Modifier le compte Portal for ArcGIS.

Pour changer le compte de service utilisé dans ArcGIS Server, reportez-vous à ArcGIS Enterprise : Modification du compte ArcGIS Server.

Pour changer le compte de service utilisé dans ArcGIS Data Store, reportez-vous à Portal for ArcGIS : Compte ArcGIS Data Store.

Restaurer le portail en rétablissant une instance opérationnelle précédente à l’aide de l’outil de sauvegarde webgisdr

Une instance opérationnelle précédente du portail peut être restaurée à l’aide de l’outil webgisdr. Reportez-vous à Portal for ArcGIS : Restaurer ArcGIS Enterprise.

Désinstaller et réinstaller Portal for ArcGIS

Avertissement : Les instructions ci-dessous impliquent de modifier des parties essentielles du déploiement ArcGIS Enterprise. Esri recommande d’effectuer une sauvegarde de la machine ArcGIS Enterprise, y compris le registre, avant de continuer. Esri ne peut pas garantir les résultats suite à des modifications incorrectes qui pourraient survenir en suivant ces consignes. Prenez toutes les précautions requises. Consultez un spécialiste des systèmes informatiques, si nécessaire.
  1. Effectuez une sauvegarde du répertoire de contenu du portail et enregistrez la sauvegarde dans un emplacement temporaire.
  2. Désinstallez Portal for ArcGIS. Pour connaître les instructions, reportez-vous à la rubrique Microsoft : Désinstaller ou supprimer des applications et des programmes dans Windows 10.
  3. Réinstallez la version précédente de Portal for ArcGIS. Pour connaître les instructions, reportez-vous à la rubrique ArcGIS Enterprise : Installation de Portal for ArcGIS.
  4. Une fois l’installation terminée, créez le site Portal for ArcGIS en le faisant pointer vers l’emplacement du répertoire de contenu d’origine.

ID d’article:000026498

Obtenir de l’aide auprès des experts ArcGIS

Contacter le support technique

Télécharger l’application Esri Support

Accéder aux options de téléchargement

Informations associées

En savoir plus sur ce sujet