PROBLÈME

impossible de mettre à jour l’ID dans le fichier ITEMINFO d’un formulaire d’enquête dans ArcGIS Survey123 Connect

Last Published: March 14, 2023

Description

Les tentatives de mise à jour de l’ID dans le fichier ITEMINFO d’un formulaire d’enquête pour qu’il corresponde à un nouvel ID d’élément de dossier ArcGIS Online dans ArcGIS Survey123 Connect échouent. L’ID mis à jour revient à l’ID du dossier ArcGIS Online d’origine.

L’ID du dossier ArcGIS Online dans lequel l’élément de formulaire est conservé est enregistré localement dans un fichier ITEMINFO lors de la première publication de l’enquête. Chaque fois que l’enquête est publiée par la suite, l’ID figurant dans le fichier ITEMINFO doit correspondre à l’ID du dossier ArcGIS Online où l’élément de formulaire est stocké. Pour plus d’informations, reportez-vous à ArcGIS Survey123 : Utiliser Survey123 avec des couches d’entités existantes.

Lorsque l’ID du fichier ITEMINFO ne correspond pas à l’ID d’élément du dossier ArcGIS Online, des comportements inattendus, tels qu’un processus de publication incomplet, se produisent lors de la publication d’un formulaire d’enquête mis à jour.

Cause

Lorsqu’un formulaire d’enquête est ouvert dans ArcGIS Survey123 Connect, les modifications apportées à l’ID correspondant dans le fichier ITEMINFO local de l’enquête ne peuvent pas être enregistrées.

Solution ou alternative

  1. Fermez ArcGIS Survey123 Connect.
  2. Ouvrez l’Explorateur de fichiers. Pour obtenir des instructions, consultez Support Microsoft : Rechercher et ouvrir Explorateur de fichiers.
  3. Accédez au dossier de l’enquête. Le fichier se trouve dans :
C:/Users/<username>/ArcGIS/My Survey Designs/<unique form ID>
  1. Mettez à jour manuellement l’ID du fichier ITEMINFO. Pour plus d’informations, reportez-vous à Problème : impossible de mettre à jour et de publier des enquêtes à partir d’ArcGIS Survey123 Connect.

ID d’article: 000029461

Recevoir des notifications et trouver des solutions liées à de nouvelles questions ou à des problèmes connus

Recevez des réponses synthétisées et des solutions en vidéo de notre nouvel agent conversationnel (IA).

Télécharger l’application Esri Support

Obtenir de l’aide auprès des experts ArcGIS

Contacter le support technique

Télécharger l’application Esri Support

Accéder aux options de téléchargement