PROBLÈME

les résultats de l’enquête ne sont pas mis à jour dans Survey123 for ArcGIS

Last Published: March 8, 2023

Description

Après avoir apporté des mises à jour et publié à nouveau un formulaire d’enquête dans Survey123 Connect for ArcGIS, le formulaire d’enquête mis à jour et les résultats n’apparaissent pas dans la vue Stakeholder dans ArcGIS Online et Portal for ArcGIS. Les résultats de l’enquête ne sont pas mis à jour dans le compte utilisateur dans Survey123 for ArcGIS, mais apparaissent dans le compte d’éditeur dans Survey123 for ArcGIS.

Le formulaire d’enquête mis à jour et les résultats n’apparaissent pas dans la vue Stakeholder dans ArcGIS Online et Portal for ArcGIS.

Old Stakeholder View in ArcGIS Online.
 

Le service d’entités republié montre le service d’entités mis à jour dans ArcGIS Online ou Portal for ArcGIS.

Updated feature service in ArcGIS Online.

Les résultats de l’enquête ne sont pas mis à jour dans le compte utilisateur dans Survey123 for ArcGIS.

User account view in Survey123 for ArcGIS.
 

Les résultats de l’enquête sont mis à jour dans le compte d’éditeur dans Survey123 for ArcGIS.

Publisher account view in Survey123 for ArcGIS.

Cause

Lors de la nouvelle publication d’une enquête dans Survey123 Connect for ArcGIS, une nouvelle couche d’entités hébergée est générée dans le dossier de l’enquête (Survey-SurveyName) dans ArcGIS Online ou Portal for ArcGIS, mais la vue de la couche d’entités Stakeholder (SurveyName_stakeholder) continue de faire référence à l’ancienne couche d’entités de l’enquête. L’autorisation d’affichage dans Survey123 for ArcGIS continue de faire référence aux anciens paramètres de partage configurés pour la vue de la couche d’entités Stakeholder.

Solution ou alternative

Pour remédier à ce problème, l’éditeur de l’enquête doit modifier les paramètres de partage de l’enquête dans Survey123 for ArcGIS afin de générer une version mise à jour de la vue de la couche d’entités Stakeholder. Pour ce faire, procédez comme suit :

  1. Dans ArcGIS Online ou Portal for ArcGIS, supprimez la vue de la couche d’entités Stakeholder qui existe (SurveyName_stakeholder) dans le dossier de l’enquête (Survey-SurveyName). Reportez-vous à l’étape 7 de la section Définir les catégories dans ArcGIS Online : Gérer le contenu : Classer le contenu.
  2. Dans Survey123 for ArcGIS, annulez le partage de l’enquête republiée aux utilisateurs. Reportez-vous à Survey123 for ArcGIS : Partager une enquête.
    1. Cliquez dans la fenêtre Submitter (Contributeur). Sous Choose who can submit data to this survey (Choisissez qui peut soumettre des données à cette enquête), décochez toutes les cases à cocher de toutes les options et cliquez sur Save (Enregistrer).
    2. Cliquez dans la fenêtre Viewer (Consultation). Sous Who can view data of this survey? (Qui peut afficher les données de cette enquête ?),décochez toutes les cases à cocher de toutes les options et cliquez sur Save (Enregistrer).
  3. Partagez à nouveau l’enquête avec les utilisateurs dans Survey123 for ArcGIS.
    1. Cliquez dans la fenêtre Submitter (Contributeur). Sous Choose who can submit data to this survey (Choisissez qui peut soumettre des données à cette enquête), cochez toutes les cases à cocher de toutes les options souhaitées et cliquez sur Save (Enregistrer).
    2. Cliquez dans la fenêtre Viewer (Consultation). Sous Who can view data of this survey? (Qui peut afficher les données de cette enquête ?),cochez toutes les cases à cocher de toutes les options souhaitées et cliquez sur Save (Enregistrer).

La vue de la couche d’entités Stakeholder fait référence au service d’entités de l’enquête republiée et les utilisateurs peuvent voir les résultats l’enquête mis à jour dans Survey123 for ArcGIS.

Remarque :
Pour veiller à utiliser la bonne version, les utilisateurs doivent supprimer la précédente version du formulaire d’enquête téléchargé dans l’application de terrain Survey123 et télécharger à nouveau le formulaire d’enquête mis à jour.

ID d’article: 000016667

Recevoir des notifications et trouver des solutions liées à de nouvelles questions ou à des problèmes connus

Recevez des réponses synthétisées et des solutions en vidéo de notre nouvel agent conversationnel (IA).

Télécharger l’application Esri Support

Informations associées

En savoir plus sur ce sujet

Obtenir de l’aide auprès des experts ArcGIS

Contacter le support technique

Télécharger l’application Esri Support

Accéder aux options de téléchargement