ERREUR

ArcGIS Desktop a rencontré une erreur d’application grave et ne peut pas continuer...

Last Published: October 1, 2021

Message d’erreur

Remarque : Cet article concerne ArcGIS versions 10.0. Les versions plus récentes d’ArcGIS sont susceptibles d’inclure des fonctionnalités différentes, des fonctionnalités qui portent d’autres noms et figurent à des endroits différents dans les menus, les commandes et les outils de géotraitement. Pour plus d’informations sur les cartes graphiques, reportez-vous à ArcMap : Questions fréquentes sur la sélection des cartes graphiques.

Au lancement du programme ArcMap, l’erreur suivante est renvoyée :

ArcGIS Desktop a rencontré une erreur d’application grave et ne peut pas continuer...

Cette erreur se produit si l’utilisateur n’est pas un membre du groupe d’administrateurs Windows local. Si l’utilisateur fait partie du groupe d’administrateurs, ArcMap démarre correctement.

Cause

Cette erreur se produit sur les machines utilisant certaines versions du pilote de carte vidéo ATI Radeon (par exemple, les versions 6.14.10.6719). Lorsque les routines OpenGL sont appelées à l’ouverture d’ArcMap, le pilote de carte vidéo tente de créer le fichier C:\moduleName.txt ou d’y consigner des informations. Par défaut, étant donné que seuls les administrateurs bénéficient d’un accès en écriture à la racine du lecteur C:\, le pilote ne peut pas écrire dans ce fichier, ce qui provoque l’arrêt inopiné du programme ArcMap.

Solution ou alternative

Pour contourner ce problème, deux options sont à votre disposition.

  • Mise à niveau du pilote vers le pilote ATI Radeon le plus récent
  • Modification des autorisations relatives au fichier C:\moduleName.txt de manière à accorder le droit de modifier ce fichier aux utilisateurs
    1. Double-cliquez sur My Computer (Poste de travail).
    2. Double-cliquez sur le lecteur C:.
    3. Cliquez avec le bouton droit sur le fichier moduleName.txt et sélectionnez Properties (Propriétés).
    4. Dans la boîte de dialogue Properties (Propriétés), cliquez sur l’onglet Security (Sécurité).
    5. Cliquez sur le groupe Users (Utilisateurs) pour le mettre en évidence.
    6. Placez une coche en regard de Modify (Modifier) sous Allow (Autoriser).
    7. Cliquez sur OK.

ID d’article: 000011095

Recevoir des notifications et trouver des solutions liées à de nouvelles questions ou à des problèmes connus

Recevez des réponses synthétisées et des solutions en vidéo de notre nouvel agent conversationnel (IA).

Télécharger l’application Esri Support

Informations associées

En savoir plus sur ce sujet

Obtenir de l’aide auprès des experts ArcGIS

Contacter le support technique

Télécharger l’application Esri Support

Accéder aux options de téléchargement