PROBLEMA

No se puede importar un certificado en ArcGIS Enterprise

Last Published: April 20, 2022

Descripción

Al intentar importar un certificado a través del Directorio del administrador de ArcGIS Server o del Directorio del administrador de Portal, aparece el siguiente error:

Error: No se puede importar el certificado. Código: 500
Imagen del mensaje de error en el Directorio del administrador de Portal

Al intentar importar el mismo certificado a través del Administrador de Internet Information Services (IIS), aparece el mensaje de error:

Error: La contraseña introducida es incorrecta.
Imagen del mensaje de error en el Administrador de IIS

Causa

Este problema se produce cuando se cumplen las siguientes condiciones:

  • El software de ArcGIS Enterprise está implementado en un equipo con Windows Server 2012 (R2) o Windows Server 2016.
  • El certificado SSL se crea como un archivo PFX utilizando el algoritmo de cifrado TripleDES-SHA1.

Solución o solución alternativa

Lleve a cabo la siguiente alternativa para resolverlo.

  1. Exporte el certificado SSL como archivo PFX. Consulte Microsoft: Para exportar los archivos .pfx y .cer para ver los pasos para hacerlo.
  2. Cuando se le pida que cree una contraseña en la ventana Seguridad, seleccione AES256-SHA256 en la lista desplegable Cifrado.
Imagen de la selección de Cifrado

Una vez que la operación de exportación se haya realizado correctamente, el archivo PFX se puede importar a ArcGIS Enterprise y Administrador de IIS.

Id. de artículo: 000024722

Recibir notificaciones y encontrar soluciones a problemas nuevos o comunes

Obtenga respuestas resumidas y soluciones de vídeo de nuestro nuevo chatbot de IA.

Descargar la aplicación de soporte de Esri

Información relacionada

Descubrir más sobre este tema

Obtener ayuda de expertos en ArcGIS

Contactar con el soporte técnico

Descargar la aplicación de soporte de Esri

Ir a opciones de descarga