PROBLEMA

No se puede conectar a ArcGIS License Manager

Last Published: September 26, 2022

Descripción

Al intentar utilizar un producto de ArcGIS con una licencia de uso concurrente, los usuarios no se pueden conectar a ArcGIS License Manager, lo que impide el uso de productos de ArcGIS tales como ArcMap, ArcGIS Pro y ArcCatalog. Iniciar estos productos puede provocar que se bloqueen o no se carguen.

Causa

Existen varias razones por las que un usuario no puede conectarse a ArcGIS License Manager; a continuación, se citan algunas:

  • Las versiones de ArcGIS License Manager y el software cliente no son compatibles.
  • ArcGIS License Manager no se está ejecutando.
  • Los servicios de ArcGIS License Manager o FlexNET no se están ejecutando.
  • Se utiliza una dirección IP de ArcGIS License Manager incorrecta para la conexión.
  • Se utilizan puertos incorrectos para conectarse a ArcGIS License Manager
  • No hay configurado un firewall para permitir conexiones a ArcGIS License Manager.

Solución o solución alternativa

A continuación, se indican seis soluciones para resolver los problemas relacionados con la conexión a ArcGIS License Manager. Siga las soluciones en el orden que se muestran e intente conectarse a ArcGIS License Manager tras cada solución.

Verificar la compatibilidad de versiones de ArcGIS License Manager y el software cliente

ArcGIS License Manager es compatible con el software cliente de la misma versión o anterior. Consulte Guía de License Manager: Productos de software compatibles para obtener más información sobre qué versiones de cliente son compatibles con la versión de ArcGIS License Manager relevante.

Verificar que ArcGIS License Manager se esté ejecutando

Un equipo cliente no puede conectarse a ArcGIS License Manager si no se está ejecutando.

  1. Vaya a Inicio > Todos los programas > ArcGIS > License Manager e inicie el Administrador del servidor de licencias en el equipo host.
  2. Compruebe si el Estado del servidor de licencias está definido como RUNNING.
Página de estado de ArcGIS License Server Administrator
  1. Si el Estado del servidor de licencias está definido como NOT RUNNING, haga clic en Iniciar > Volver a leer las licencias.

Reiniciar los servicios de licenciamiento de ArcGIS License Manager y FlexNET

ArcGIS License Manager puede detener su ejecución debido a ajustes concretos de los servicios de Windows. La modificación de estos ajustes garantiza que ArcGIS License Manager se ejecute automáticamente.

  1. Ejecute services.msc.
  2. Busque ArcGIS License Manager en la lista. Haga clic con el botón derecho en ArcGIS License Manager y seleccione Propiedades.
Página de servicios de ArcGIS License Manager
  1. Haga clic en la flecha desplegable Tipo de inicio y seleccione Automático. Haga clic en Inicio > Aceptar.
Página de propiedades de ArcGIS License Manager
  1. Busque FlexNet Licensing Service en la lista. Haga clic con el botón derecho en FlexNet Licensing Service y seleccione Propiedades.
  2. Haga clic en la flecha desplegable Tipo de inicio y seleccione Automático. Haga clic en Inicio > Aceptar.
  3. Inicie el Administrador del servidor de licencias. Compruebe el Estado del servidor de licencias y asegúrese de que esté definido como RUNNING.
  4. Conéctese a ArcGIS License Manager a través del Administrador de ArcGIS.

Conectarse a ArcGIS License Manager a través de una dirección IP

Conectarse a ArcGIS License Manager a través de una dirección IP garantiza que el Administrador de ArcGIS acceda al ArcGIS License Manager correcto.

  1. Ejecute la línea de comandos en el equipo host.
  2. Introduzca ipconfig y pulse Intro. Tome nota de la dirección IPV4.
  3. Inicie el Administrador de ArcGIS en el equipo cliente.
  4. Haga clic en Escritorio en el panel izquierdo del Administrador de ArcGIS. Haga clic en Cambiar en el panel derecho.
  5. Introduzca la dirección IP de ArcGIS License Manager. Haga clic en Aceptar.

Conectarse a ArcGIS License Manager a través de un puerto

ArcGIS License Manager puede ejecutarse en los puertos del 27000 al 27009. Otros programas pueden interferir en la conexión si se utiliza el mismo puerto, lo cual impide que el Administrador de ArcGIS se conecte a ArcGIS License Manager. Para evitarlo, conéctese a ArcGIS License Manager a través de un puerto específico.

  1. Inicie el Administrador de ArcGIS en el equipo cliente.
  2. Haga clic en Escritorio en el panel izquierdo del Administrador de ArcGIS. Haga clic en Cambiar en el panel derecho.
  3. Introduzca el nombre de host y el número de puerto en el formato siguiente: "puerto@nombredehost". Haga clic en Aceptar.
Imagen del cuadro de diálogo Cambiar License Manager

Modificar el archivo service.txt

De forma predeterminada, el archivo service.txt no indica ningún puerto específico que deba utilizar ArcGIS License Manager. Al editar este archivo se bloquea ArcGIS License Manager en un puerto específico no utilizado.

  1. Vaya al siguiente directorio y abra service.txt en el equipo host.
C:\Archivos de programa\ArcGIS\License10.x\bin
  1. De forma predeterminada, el contenido del archivo es el siguiente:
SERVER this_host ANY VENDOR ARCGIS FEATURE ACT ARCGIS 1 permanent 1 7ED49106D630
  1. Edite el contenido del archivo como se muestra a continuación:
SERVER this_host ANY 27000 VENDOR ARCGIS port=27004 FEATURE ACT ARCGIS 1 permanent 1 7ED49106D630
Nota: Se pueden utilizar todos los valores entre 27000 y 27009 para VENDOR ARCGIS PORT.
  1. Guarde el archivo servicio.txt.
  2. Conéctese a ArcGIS License Manager a través del Administrador de ArcGIS.

Configurar el firewall

Las configuraciones de firewall pueden impedir que ArcGIS License Manager reciba y establezca conexiones. El firewall debe estar configurado para permitir que ArcGIS License Manager funcione a través de él.

  1. Vaya a Panel de control > Firewall de Windows > Configuración avanzada.
  2. Haga clic en Reglas de entrada en el panel izquierdo.
Imagen de la ventana Reglas de entrada de firewall de Windows
  1. Haga clic en Nueva regla en el panel derecho. Se ejecuta el asistente Nueva regla de entrada.
  2. Seleccione Programa > Siguiente.
Imagen del paso de selección Tipo de regla en el asistente Nueva regla de entrada
  1. Seleccione Esta ruta de acceso del programa. Vaya al siguiente directorio, seleccione lmgrd.exe > Abrir > Siguiente:
C:\Archivos de programa(x86)\ArcGIS\License10.x\bin
Imagen del paso de selección Programa en el asistente Nueva regla de entrada
  1. Seleccione Permitir la conexión > Siguiente.
Imagen del paso Acción en el asistente Nueva regla de entrada
  1. Active las casillas de verificación de todas las opciones disponibles y haga clic en Siguiente.
Imagen del paso de selección Perfil en el asistente Nueva regla de entrada
  1. Póngale un nombre a la regla (por ejemplo, ArcGIS License Manager) y haga clic en Finalizar.
Imagen del paso de selección Nombre en el asistente Nueva regla de entrada
  1. Repita los mismos pasos para los siguientes archivos: ARCGIS.exe y LSAdmin.exe. Ambos archivos están almacenados en la misma ubicación especificada en el paso 5.
  2. Repita el proceso "Configurar el firewall" para Reglas de salida.

Id. de artículo: 000019755

Recibir notificaciones y encontrar soluciones a problemas nuevos o comunes

Obtenga respuestas resumidas y soluciones de vídeo de nuestro nuevo chatbot de IA.

Descargar la aplicación de soporte de Esri

Información relacionada

Descubrir más sobre este tema

Obtener ayuda de expertos en ArcGIS

Contactar con el soporte técnico

Descargar la aplicación de soporte de Esri

Ir a opciones de descarga