Descripción
Al intentar utilizar un producto de ArcGIS con una licencia de uso concurrente, los usuarios no se pueden conectar a ArcGIS License Manager, lo que impide el uso de productos de ArcGIS tales como ArcMap, ArcGIS Pro y ArcCatalog. Iniciar estos productos puede provocar que se bloqueen o no se carguen.
Causa
Existen varias razones por las que un usuario no puede conectarse a ArcGIS License Manager; a continuación, se citan algunas:
- Las versiones de ArcGIS License Manager y el software cliente no son compatibles.
- ArcGIS License Manager no se está ejecutando.
- Los servicios de ArcGIS License Manager o FlexNET no se están ejecutando.
- Se utiliza una dirección IP de ArcGIS License Manager incorrecta para la conexión.
- Se utilizan puertos incorrectos para conectarse a ArcGIS License Manager
- No hay configurado un firewall para permitir conexiones a ArcGIS License Manager.
Solución o solución alternativa
A continuación, se indican seis soluciones para resolver los problemas relacionados con la conexión a ArcGIS License Manager. Siga las soluciones en el orden que se muestran e intente conectarse a ArcGIS License Manager tras cada solución.
Verificar la compatibilidad de versiones de ArcGIS License Manager y el software cliente
ArcGIS License Manager es compatible con el software cliente de la misma versión o anterior. Consulte Guía de License Manager: Productos de software compatibles para obtener más información sobre qué versiones de cliente son compatibles con la versión de ArcGIS License Manager relevante.
Verificar que ArcGIS License Manager se esté ejecutando
Un equipo cliente no puede conectarse a ArcGIS License Manager si no se está ejecutando.
- Vaya a Inicio > Todos los programas > ArcGIS > License Manager e inicie el Administrador del servidor de licencias en el equipo host.
- Compruebe si el Estado del servidor de licencias está definido como RUNNING.
- Si el Estado del servidor de licencias está definido como NOT RUNNING, haga clic en Iniciar > Volver a leer las licencias.
Reiniciar los servicios de licenciamiento de ArcGIS License Manager y FlexNET
ArcGIS License Manager puede detener su ejecución debido a ajustes concretos de los servicios de Windows. La modificación de estos ajustes garantiza que ArcGIS License Manager se ejecute automáticamente.
- Ejecute services.msc.
- Busque ArcGIS License Manager en la lista. Haga clic con el botón derecho en ArcGIS License Manager y seleccione Propiedades.
- Haga clic en la flecha desplegable Tipo de inicio y seleccione Automático. Haga clic en Inicio > Aceptar.
- Busque FlexNet Licensing Service en la lista. Haga clic con el botón derecho en FlexNet Licensing Service y seleccione Propiedades.
- Haga clic en la flecha desplegable Tipo de inicio y seleccione Automático. Haga clic en Inicio > Aceptar.
- Inicie el Administrador del servidor de licencias. Compruebe el Estado del servidor de licencias y asegúrese de que esté definido como RUNNING.
- Conéctese a ArcGIS License Manager a través del Administrador de ArcGIS.
Conectarse a ArcGIS License Manager a través de una dirección IP
Conectarse a ArcGIS License Manager a través de una dirección IP garantiza que el Administrador de ArcGIS acceda al ArcGIS License Manager correcto.
- Ejecute la línea de comandos en el equipo host.
- Introduzca ipconfig y pulse Intro. Tome nota de la dirección IPV4.
- Inicie el Administrador de ArcGIS en el equipo cliente.
- Haga clic en Escritorio en el panel izquierdo del Administrador de ArcGIS. Haga clic en Cambiar en el panel derecho.
- Introduzca la dirección IP de ArcGIS License Manager. Haga clic en Aceptar.
Conectarse a ArcGIS License Manager a través de un puerto
ArcGIS License Manager puede ejecutarse en los puertos del 27000 al 27009. Otros programas pueden interferir en la conexión si se utiliza el mismo puerto, lo cual impide que el Administrador de ArcGIS se conecte a ArcGIS License Manager. Para evitarlo, conéctese a ArcGIS License Manager a través de un puerto específico.
- Inicie el Administrador de ArcGIS en el equipo cliente.
- Haga clic en Escritorio en el panel izquierdo del Administrador de ArcGIS. Haga clic en Cambiar en el panel derecho.
- Introduzca el nombre de host y el número de puerto en el formato siguiente: "puerto@nombredehost". Haga clic en Aceptar.
Modificar el archivo service.txt
De forma predeterminada, el archivo service.txt no indica ningún puerto específico que deba utilizar ArcGIS License Manager. Al editar este archivo se bloquea ArcGIS License Manager en un puerto específico no utilizado.
- Vaya al siguiente directorio y abra service.txt en el equipo host.
C:\Archivos de programa\ArcGIS\License10.x\bin
- De forma predeterminada, el contenido del archivo es el siguiente:
SERVER this_host ANY VENDOR ARCGIS FEATURE ACT ARCGIS 1 permanent 1 7ED49106D630
- Edite el contenido del archivo como se muestra a continuación:
SERVER this_host ANY 27000 VENDOR ARCGIS port=27004 FEATURE ACT ARCGIS 1 permanent 1 7ED49106D630
Nota: Se pueden utilizar todos los valores entre 27000 y 27009 para VENDOR ARCGIS PORT.
- Guarde el archivo servicio.txt.
- Conéctese a ArcGIS License Manager a través del Administrador de ArcGIS.
Configurar el firewall
Las configuraciones de firewall pueden impedir que ArcGIS License Manager reciba y establezca conexiones. El firewall debe estar configurado para permitir que ArcGIS License Manager funcione a través de él.
- Vaya a Panel de control > Firewall de Windows > Configuración avanzada.
- Haga clic en Reglas de entrada en el panel izquierdo.
- Haga clic en Nueva regla en el panel derecho. Se ejecuta el asistente Nueva regla de entrada.
- Seleccione Programa > Siguiente.
- Seleccione Esta ruta de acceso del programa. Vaya al siguiente directorio, seleccione lmgrd.exe > Abrir > Siguiente:
C:\Archivos de programa(x86)\ArcGIS\License10.x\bin
- Seleccione Permitir la conexión > Siguiente.
- Active las casillas de verificación de todas las opciones disponibles y haga clic en Siguiente.
- Póngale un nombre a la regla (por ejemplo, ArcGIS License Manager) y haga clic en Finalizar.
- Repita los mismos pasos para los siguientes archivos: ARCGIS.exe y LSAdmin.exe. Ambos archivos están almacenados en la misma ubicación especificada en el paso 5.
- Repita el proceso "Configurar el firewall" para Reglas de salida.