PROBLEMA

El botón Cambiar del Administrador de ArcGIS está deshabilitado

Last Published: March 15, 2021

Descripción

En la carpeta Desktop del Administrador de ArcGIS, el botón Cambiar para acceder a ArcGIS License Manager está deshabilitado.

El botón Cambiar para acceder al ArcGIS License Manager no está disponible en la ventana Administrador de ArcGIS
Nota: En ArcGIS 9.3.x o versiones anteriores, el Administrador de ArcGIS se conoce como Administrador de Desktop.

Causa

Estas son las causas conocidas de este problema:

  • El Administrador de ArcGIS se inicia con una cuenta de usuario sin privilegios administrativos.
  • El Administrador de ArcGIS se inicia mientras ArcGIS Desktop se está ejecutando.
  • Faltan archivos .dll o están dañados.

Solución o solución alternativa

Utilice una de las siguientes alternativas para corregir el problema:

Ejecutar el Administrador de ArcGIS con permisos de administrador

  1. Haga clic en Menú Inicio de Windows > Todos los programas > ArcGIS.
  2. Haga clic con el botón derecho en Administrador de ArcGIS y seleccione Ejecutar como administrador.

Cerrar todas las aplicaciones de ArcGIS Desktop antes de ejecutar el Administrador de ArcGIS

Asegúrese de que las aplicaciones de ArcGIS Desktop como ArcMap y ArcCatalog estén cerradas antes de iniciar el Administrador de ArcGIS.

Cambiar el nivel de producto y licencia a través del archivo de lotes

  1. Inicie el Bloc de notas.
  2. Introduzca lo siguiente en el Bloc de notas:
set Esri_SEAT_PREFERENCE=Float set ESRI_SOFTWARE_CLASS=Viewer set ESRI_LICENSE_HOST=<name of ArcGIS License Manager> set path=<path> (ejemplo:C:\Archivos de programa (x86)\ArcGIS\Desktop10.7\bin) ArcMap.exe
  1. Guarde el archivo como un archivo .bat.
  2. Ejecute el archivo para iniciar ArcMap con el nivel de producto y licencia preferidos.
Nota: Cambiar la clase de puesto permite el uso de un nivel de licencia específico. Para obtener más información sobre las clases de puesto y los niveles de licencia que representan, consulte ArcGIS Desktop: Instalar ArcGIS Desktop de forma automática.

Cambiar el nivel de producto y licencia a través del Editor del Registro de Windows

Advertencia: Las instrucciones que se indican a continuación incluyen hacer cambios en partes fundamentales del sistema operativo. Se recomienda que realice una copia de seguridad del sistema operativo y de los archivos, incluido el registro, antes de continuar. Si es necesario, consulte con un profesional en sistemas informáticos cualificado. Esri no puede garantizar resultados por modificaciones incorrectas cuando sigue estas instrucciones. Por tanto, utilícelos asumiendo el riesgo correspondiente.

Edite las siguientes claves de registro según el nivel de licencia.

  1. Abra el Editor del Registro. Haga clic en Inicio > Ejecutar, y escriba regedit. Haga clic en Aceptar.
  2. Vaya a la carpeta de licencias en la siguiente ruta:
Para equipos de 32 bits: HKEY_LOCAL_MACHINE\SOFTWARE\ESRI\License10.x Para equipos de 64 bits: HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\ESRI\License10.x
La ruta a la carpeta de licencia en el Editor del Registro
  1. Haga clic con el botón derecho en la cadena SOFTWARE_CLASS y haga clic en Modificar.
  2. Cambie los datos del valor según el nivel de licencia de la siguiente manera:
    • Para Basic: Visor
    • Para Standard: Editor
    • Para Advanced: Professional
Modificar los datos del valor según el nivel de licencia en la ventana Editar cadena de caracteres para SOFTWARE_CLASS
  1. Haga clic con el botón derecho en la cadena SEAT_PREFERENCE y haga clic en Modificar.
  2. Cambie los datos del valor según el tipo de licencia como se describe a continuación:
    • Para uso concurrente: Flotante
    • Para uso único: Fijo
Modificar los datos del valor según el tipo de licencia en la ventana Editar cadena de caracteres para SEAT_PREFERENCE

Para obtener más información, consulte los vínculos que aparecen a continuación en Información relacionada.

Id. de artículo: 000012046

Recibir notificaciones y encontrar soluciones a problemas nuevos o comunes

Obtenga respuestas resumidas y soluciones de vídeo de nuestro nuevo chatbot de IA.

Descargar la aplicación de soporte de Esri

Información relacionada

Descubrir más sobre este tema

Obtener ayuda de expertos en ArcGIS

Contactar con el soporte técnico

Descargar la aplicación de soporte de Esri

Ir a opciones de descarga