Descripción
Al publicar una encuesta de ArcGIS Survey123 Connect en ArcGIS Online o en el portal de ArcGIS Enterprise, el proceso se carga, pero no se completa, deteniéndose en "Crear elemento de formulario", como se muestra en la imagen siguiente.
Causa
- El XLSForm con el mismo nombre se utiliza en varias encuestas. El uso del mismo nombre de XLSForm en varias encuestas causa problemas porque cada encuesta debe tener un Id. de formulario único.
- XLSForm contiene archivos de gran tamaño en la carpeta de contenido multimedia. Un gran volumen de archivos de imagen, archivos de audio o archivos de mapa base personalizados de gran tamaño provoca problemas durante la publicación.
Solución o solución alternativa
Guardar el XLSForm con un nombre diferente antes de crear una nueva encuesta
- En el equipo local, vaya a la carpeta de la encuesta ubicada en:
C:\Users\<username\ArcGIS\My Survey Designs\<survey_title>
- Cambie el nombre y guarde el XLSForm de la encuesta. Asegúrese de que no haya encuestas o capas de entidades con el mismo nombre en ArcGIS Online o en el portal de ArcGIS Enterprise.
- Cree una nueva encuesta con XLSForm.
- En ArcGIS Survey123 Connect, haga clic en Nueva encuesta.
- Inicie sesión en la organización de ArcGIS.
- En Título, especifique un título para la nueva encuesta.
- En Crear un nuevo formulario de encuesta, seleccione la opción Archivo.
- Para el archivo XLSForm, haga clic en Seleccionar, busque y seleccione el XLSForm guardado en el paso 1.
- Haga clic en Crear encuesta.
- Haga clic en el botón Publicar para publicar la nueva encuesta.
Eliminar el archivo grande de la carpeta de contenido multimedia de la encuesta
- Abra la encuesta en ArcGIS Survey123 Connect y haga clic en la pestaña Multimedia.
- Haga clic en Abrir carpeta de contenido multimedia, vaya al elemento y elimínelo.
Como alternativa, elimine directamente el elemento de la carpeta de contenido multimedia del equipo local ubicada en:
C:\Users\<username>\ArcGIS\My Survey Designs\<survey_title>\media