PROBLEM

Unable to update the ID in the ITEMINFO file of a survey form in ArcGIS Survey123 Connect

Last Published: March 14, 2023

Description

Attempts to update the ID in the ITEMINFO file of a survey form to match a new ArcGIS Online folder item ID in ArcGIS Survey123 Connect fails. The updated ID reverts to the ID of the original ArcGIS Online folder.

The ID of the ArcGIS Online folder where the form item is kept is recorded locally in an ITEMINFO file when the survey is first published. Each time the survey is subsequently published, the ID in the ITEMINFO file must match the ID of the ArcGIS Online folder where the form item is stored. Refer to ArcGIS Survey123: Use Survey123 with existing feature layers for more information.

When the ID in the ITEMINFO file does not match the item ID of the ArcGIS Online folder, unexpected behaviors, such as an incomplete publishing process, occur while publishing an updated survey form.

Cause

When a survey form is opened in ArcGIS Survey123 Connect, any changes made to its ID in the local ITEMINFO file of the survey are unable to be saved successfully.

Solution or Workaround

  1. Close ArcGIS Survey123 Connect.
  2. Open File Explorer. Refer to Microsoft Support: Find and open File Explorer for instructions.
  3. Navigate to the survey folder. The file is located in:
C:/Users/<username>/ArcGIS/My Survey Designs/<unique form ID>
  1. Manually update the ID of the ITEMINFO file. Refer to Problem: Unable to update and publish surveys from ArcGIS Survey123 Connect for more information.

Article ID:000029461

Software:
  • ArcGIS Survey123 Connect

Get help from ArcGIS experts

Contact technical support

Download the Esri Support App

Go to download options