English

FAQ: How do I enable TLS 1.2 for ArcGIS Runtime SDK for Java?

Question

How do I enable TLS 1.2 for ArcGIS Runtime SDK for Java?

Answer

Note:
See the Product Life Cycle pages on the Esri Support site for the support status of each released version of ArcGIS Runtime SDK for Java.

On all supported platforms, ArcGIS Runtime SDK versions 100.x and 10.2.x support TLS 1.2 without any application changes, provided the Java 8 Update 181 or later is used.
However, ArcGIS 10.2.x applications executing in a Java 7 environment return javax.net.ssl.SSLException errors when using TLS.  
Esri recommends that ArcGIS 10.2.x applications are executed on the Java 8 Update 181 or later.

Note:
See the Esri Support TLS Page for information on how to use TLS 1.2 with other Esri products.

Related Information