ERROR

An error occurred while trying to open LSAdmin.exe

Last Published: September 28, 2022

Error Message

Launching ArcGIS License Manager returns the following error:

Error:   
An error occurred while trying to open LSAdmin.exe.
The error message when launching ArcGIS License Manager

LSAdmin.exe is a component of License Server Administrator, and is found in specific locations.

For ArcGIS License Manager 10.x:

C:\Program Files (x86)\ArcGIS\License10.x\bin

For ArcGIS License Manager 2018 and newer:

C:\Program Files (x86)\ArcGIS\LicenseManager\bin

Cause

The current version of ArcGIS License Manager is corrupt.

Solution or Workaround

To resolve this error, follow the steps listed below:

  1. Backup all concurrent use licenses on the machine. Stop the ArcGIS License Manager service, and copy the FLEXnet folder in the following directory:
C:\ProgramData
Note:
The ProgramData folder is a hidden folder. Refer to Microsoft: Show hidden files to show hidden folders.
  1. Uninstall ArcGIS License Manager. Refer to Microsoft: Repair apps and programs in Windows to uninstall the software.
  2. Log in to My Esri, and download ArcGIS License Manager. Navigate to the following locations to download ArcGIS License Manager.
    • For ArcGIS License Manager 2018 and newer, navigate to My Organizations > Downloads > Products > ArcGIS Desktop > ArcGIS License Manager.
    • For ArcGIS License Manager 10.6 and older, navigate to My Organizations > Downloads > Products > ArcGIS License Manager.
  1. Run the setup file to reinstall ArcGIS License Manager.
  2. Replace the new FLEXnet folder with the backup folder from Step 1.
Note:
The backup FLEXnet folder must be used on the same machine. Using the backup folder on another machine may result in an error.

Article ID:000018967

Software:
  • ArcMap

Get help from ArcGIS experts

Contact technical support

Download the Esri Support App

Go to download options

Related Information

Discover more on this topic