Problem: ArcGIS Pro stops responding after login
Description
The ArcGIS Pro Sign In dialog box stops responding, causing log in attempts to fail, which can prompt errors relating to certification, licensing, or an invalid username.
Cause
The ArcGIS Pro registry entry is corrupt. This may occur when multiple versions of ArcGIS for Desktop are installed on the same machine and the environment variable settings in the operating system's registry is modified to accommodate this scenario.
Solution or Workaround
The following workarounds are possible solutions for this problem.
Note: Before beginning, verify that an active ArcGIS Pro license is allocated. The following ArcGIS Online Help document describes how to do this: Manage licenses.Workaround 1: Rename the ArcGIS Pro folders
Note: The AppData folder is a hidden folder. The following Microsoft Support document describes how to show hidden files: Show hidden files
- Navigate to the following paths:
- C:\Users\<computer name>\AppData\Roaming\ESRI, and
- C:\Users\<computer name>\AppData\Local\ESRI
- Rename the ArcGISpro folder to ArcGISpro_old.
Note: Renaming the ArcGISpro folder resets ArcGIS Pro. Launch ArcGIS Pro to recreate the ArcGIS Pro folder.
- Restart the ArcGIS Pro machine.
- Open ArcGIS Pro.
- Log in to ArcGIS Pro to verify.
Note: The ProgramData folder is a hidden folder.
- Navigate to C:\ProgramData\FLEXnet.
- Rename the FLEXnet folder to FLEXnet_old.
Note: Renaming the FLEXnet folder resets FLEXnet. Launch ArcGIS Pro to recreate the FLEXnet folder.
- Restart the ArcGIS Pro machine.
- Open ArcGIS Pro.
- Log in to ArcGIS Pro to verify.
Warning: The given instructions include making changes to essential parts of your operating system. It is recommended that you backup your operating system and files, including the registry, before proceeding. Consult with a qualified computer systems professional, if necessary. Esri cannot guarantee results from incorrect modifications while following these instructions. Therefore, use caution and proceed at your own risk.
- Navigate to Windows Start, in the Search program and files search bar, type regedit.
- Open the Registry Editor with an administrator account.

- Delete the following registry sub keys from the HKEY_CURRENT_USER hive:
- HKEY_CURRENT_USER\Software\ESRI\ArcGIS Online for Pro
- HKEY_CURRENT_USER\Software\ESRI\ArcGISPro
- HKEY_CURRENT_USER\Software\ESRI\ArcGIS Online
- HKEY_CURRENT_USER\Software\ESRI\ArcGISPro1.0
- Restart the ArcGIS Pro machine.
- Open ArcGIS Pro.
- Log in to ArcGIS Pro to verify.
Related Information
- How To: Get started with ArcGIS Pro using concurrent or single-use licenses
- Bug: ArcGIS Pro 1.0 fails to sign-in with an error that it fails to initialize license
- FAQ: What are some common questions about ArcGIS Pro Licensing?
- ArcGIS Pro Help: Licensing ArcGIS Pro
Last Published: 9/22/2020
Article ID: 000013863
Software: ArcGIS Pro 1.4.1, 1.4, 1.3.1, 1.3, 1.2