PROBLEM

Missing toolbar

Last Published: October 18, 2021

Description

A toolbar that was available at a previous point in an ArcMap session may not be visible when working on the same map document.

Cause

The toolbar may be turned off, hidden, or there may be errors with the map document (MXD).

Solution or Workaround

  1. Open the map document with the missing toolbar. Ensure it is the only program open.
  2. On the Customize menu, select Customize Mode. Click the Toolbars tab and check the check box of the missing toolbar to make it visible on the map.
The Customize menu to turn on or off missing toolbar
Note:
While toggling the tool's visibility on or off, make sure to look for the toolbar on the display. Begin by checking the standard toolbar, then review the remainder of the display.
  1. If the toolbar does not display after toggling it on or off, start a new blank map document to see if it displays on the new map. If the toolbar is available in the new blank map document, the existing map document may be corrupt. To start working on a new map document without missing toolbars:
    1. Open the existing map document (with the missing toolbar) side-by-side with a new blank map document.
    2. Select all the layers in the corrupt map document's table of contents.
    3. Drag them across to the blank map document, or copy and paste them into the new map document.
    4. Save the new map document.

If the above steps fail and the toolbar does not display, there may be an issue with the map template. Follow the steps below to refresh the map template.

Generate a new default template

MXD files are based on a default ArcMap template, Normal.mxt. When the MXD is corrupted, the default template can be renamed to render it invalid, and a new default ArcMap template is generated when ArcMap is re-started.

Warning:
The following workaround may have unintended results. Renaming the Normal.mxt template may remove any ArcMap customization such as activated toolbars, toolbar or panel positioning, and folder or database connections.
  1. Close ArcCatalog and ArcMap.
  2. Navigate to root: C:\Users\CURRENT_USERNAME\AppData\Roaming\ESRI\Desktop10.x\ArcMap\Templates
Note:
The Application Data folder may be hidden. If so, go to Start > Control Panel > Folder Options. Click the View tab and select Show hidden files, folders, and drives.
  1. Open the Templates folder.
  2. Right-click the file Normal.mxt file and rename it. For example, Normal.mxt.old.
  3. Re-start ArcMap.
Note:
Any custom toolbar or folder connections are removed because the procedure reverts the normal ArcMap template to the original installed template. If these changes are not favorable, revert them by deleting Normal.mxt and renaming Normal.mxt.old to Normal.mxt in the directory above.

Article ID:000011505

Software:
  • ArcMap 10 x

Get help from ArcGIS experts

Contact technical support

Download the Esri Support App

Go to download options