PROBLEM

Unable to publish 3D scene layer as a web scene service due to cache generation fail

Last Published: April 8, 2025

Description

Attempts to publish 3D scene layers, such as multipatch data, as a web scene service fail due to cache generation failure.

The following two error messages are returned in the Jobinfo error report file:

esriJobMessageTypeError: <Scene Server>. Layer ID: <layerID>, Cache generation failed.
esriJobMessageTypeError: Failed to execute (Manage Scene Cache).

The below Severe error messages are  returned in the ArcGIS Server logs:

"Error executing tool. Manage Scene Cache Job ID: <Job ID>: ERROR 001812: Unable to connect to the database used for scene caches (The server took too long to answer. The client has timed out. (status code 28).). Failed to execute (Manage Scene Cache)"
"Failed to connect to couchDB."
"Failed to delete the cache (normal if service hasn't been cached)"
"Failed to delete the cache (normal if service hasn't been cached)."

These messages are observed on the ArcGIS Pro Sharing job logs:

Error: Failed to create the service. Failed to execute (PublishServiceDefinition).
Error: {"error":{"code":404,"message":"Service Hosted/”Service_name”/MapServer not found ","details":[]}}
Error: code:404, Service Hosted/”Service_name”/MapServer not found , No resource could be found at that address.
ErrorMessage: Failed to publish web layer
ErrorMessage: Failed to publish web layer “Service_name”
ErrorMessage: Failed to publish one or more web layers
ErrorThe containing process for 'System/SceneCachingTools' job '<jobID>' has crashed.

Error message in Scene Viewer on Portal for ArcGIS:

<layername> cannot be added. Scene service is missing root node

Cause

The Tile Cache Data Store machines communicate with one another through ports to synchronize and share cached tiles, this allows the server to request and retrieve cached tiles as needed. If the hosting server has a tile cache data store, you can publish hosted scene layers from ArcGIS Enterprise or publish from a scene layer package that you upload to the portal website. Ensure that ports 29080 and 29081 are open and not used by any other applications on the server.

Solution or Workaround

Follow these steps while logged in to the ArcGIS Server account on each ArcGIS Server machine in the hosting server site.

  1. In the Windows Search bar, type internet options, and press Enter.
  2. In the Internet Options window, click the Advanced tab.
  3. In the Settings section, scroll down to the Security section, and check the Use SSL 3.0 checkbox.
  4. Click OK to apply changes and close the Internet Options window.

Check and validate the Tile Cache Data Store from ArcGIS Server. Check and verify the ports 29080 and 29081 are allowed through the firewall and not used by any other applications on the server.

Article ID: 000033867

Software:
  • ArcGIS Enterprise

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