PROBLEM

Web maps in web apps are blank when opened on Android devices

Last Published: September 23, 2024

Description

When opening a web map of ArcGIS Experience Builder or ArcGIS Instant Apps in a mobile browser, the map is blank, as shown in the image below.

The map is blank when opening the web map of ArcGIS Experience Builder in the mobile browser

Cause

The Android version of the device has not been updated and thus the mobile browser is not up to date. Devices running Android 13 and earlier might have an earlier version of the mobile browser. The mobile browser cannot display the web map due to compatibility issues.

Solution or Workaround

Note:
This issue is not applicable on iOS devices.

Update the Android device operating system

Update the Android device operating system to the latest version. This ensures the mobile browser is up to date and capable of displaying web maps without compatibility issues. Refer to Android Help: Check & update your Android version for instructions.

Use the Firefox mobile browser

Open the web map in a Firefox mobile browser. Refer to Mozilla: Firefox for Mobile for more information.

Article ID: 000032529

Software:
  • ArcGIS Online
  • ArcGIS Experience Builder

Receive notifications and find solutions for new or common issues

Get summarized answers and video solutions from our new AI chatbot.

Download the Esri Support App

Related Information

Discover more on this topic

Get help from ArcGIS experts

Contact technical support

Download the Esri Support App

Go to download options