Description
When opening an ArcGIS Experience Builder web app, the web map in the Map widget cannot be viewed and the following message is returned:
Error:
Creating map failed.
The image below shows an ArcGIS Experience builder web app with the message displayed in the Map widget.
Cause
- The web map sharing level is not set appropriately in ArcGIS Online.
- The web map is corrupted, broken, or deleted and no longer exists.
- The Map widget in ArcGIS Experience Builder is corrupted or broken.
Solution or Workaround
Change the sharing level of the web map
Note:
The workaround below can only be performed by the web map owner or members with sharing privileges.
In ArcGIS Online, change the sharing level of the web map. Refer to ArcGIS Online: Share items for instructions. In this example, the sharing level is set to Everyone (public).
Note:
The following two workarounds can only be performed by the ArcGIS Experience Builder web app owner, administrators, or members with editing privileges. Refer to ArcGIS Experience Builder: Manage experiences for more information.
Replace the web map in ArcGIS Experience Builder
- Sign in to ArcGIS Online.
- Create a new web map with the same feature layers and configurations in ArcGIS Online Map Viewer. Refer to ArcGIS Online: Get started creating maps (Map Viewer) and ArcGIS Online: Web maps for more information.
- Share the web map at the appropriate sharing level.
- Open the existing web app in ArcGIS Experience Builder.
- On the Content tab of the Map widget, click Remove
on the corrupted or broken web map. - Click Select map and select the newly created web map as the widget’s source.
- Save, preview and publish the web app.
Replace the Map widget in ArcGIS Experience Builder
- Open the web app in ArcGIS Experience Builder.
- Select the Map widget on the canvas and click the Delete icon.
- Add a new Map widget to the web app and select the same web map as the widget’s source.
- Save, preview, and publish the web app.