PROBLEM

Unable to view a hosted scene layer in Portal for ArcGIS

Last Published: September 21, 2021

Description

When attempting to view a hosted scene layer in Portal for ArcGIS published from ArcGIS Pro, the layer does not load, and returns the following error message:

Error:   
<layerName> cannot be added
Scene service is missing root node.
The error message is returned when attempting to view the hosted scene layer in Portal for ArcGIS.

Attempting to delete this layer in Portal for ArcGIS fails, returning the following error message:

Error:   
Some items were not deleted because they are delete protected or have dependent items.
The error message is returned when attempting to delete the hosted scene layer in Portal for ArcGIS.

Cause

The SceneCachingControllers geoprocessing service in ArcGIS Server Manager is not running. This prevents the creation of scene layer nodes in the CouchDB tile cache data store.

The 'Stopped' status indicates the geoprocessing service is not running.

Solution or Workaround

  1. Navigate to the ArcGIS Server Manager site, and log in as an administrator. The default path is:
https://machineName.domain.com/webadaptorName/manager
  1. Navigate to Services > System.
  2. Search for the SceneCachingControllers geoprocessing service.
  3. Click the Start Click the Start icon to start the geoprocessing service. icon to start the geoprocessing service.

Hosted scene layers can now be viewed and/or deleted in Portal for ArcGIS.

Article ID: 000026080

Software:
  • Portal for ArcGIS
  • ArcGIS Server

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