PROBLEM

Unable to retrieve users from Active Directory in the ArcGIS Enterprise portal

Last Published: May 26, 2025

Description

The ArcGIS Enterprise portal is configured to use Windows Active Directory for authentication. Although the JSON is valid, testing the connection in the Portal Administrator Directory returns the following error, and searches for users within the directory return no results:

Error:
Failed to connect to the user store.
Code: 500
The error message

Cause

The issue is due to a misconfiguration in the Active Directory identity store settings within the ArcGIS Enterprise portal. The misconfiguration can be caused by various issues, such as a recently reset password or a no longer available user account.

Solution or Workaround

Reconfigure the Active Directory JSON settings. Refer to Portal for ArcGIS: Use your portal with LDAP or Active Directory and portal-tier authentication for instructions.

Article ID: 000036068

Software:
  • Portal for ArcGIS
  • ArcGIS Enterprise

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