PROBLEM

Unable to license ArcGIS Pro with a Named User license using ArcGIS Enterprise 11.4 credentials

Last Published: July 4, 2025

Description

When signing in to ArcGIS Pro using a Named User license with ArcGIS Enterprise credentials, the following error message is returned:

Error:
An unknown error has occurred. Contact your administrator to check that the license manager is running with valid licenses.

Starting with ArcGIS Enterprise 11.4, ArcGIS Pro users with a Named User license can sign in directly using their organization credentials without requiring ArcGIS License Manager.

Cause

The portal URL provided when creating the portal license file is incorrect or incomplete. To enable access to ArcGIS Pro, the public portal URL in the license file must match the ArcGIS Enterprise portal URL. Refer to ArcGIS Pro: ArcGIS Enterprise 11.4 and later versions for more information.

Examples of incorrect URLs include:

  • Including port number 7443 in the portal URL
  • Omitting the web adaptor name in the portal URL

Solution or Workaround

  1. Generate a new license file using the correct ArcGIS Enterprise portal URL. Refer to ArcGIS Enterprise: Obtain a portal license file from My Esri for instructions. In Step 7, enter the ArcGIS Enterprise organization URL as follows:
https://webadaptorhost.domain.com/webadaptorname
The correct portal URL when generating a new license file in My Esri
  1. Import the new license file to the ArcGIS Enterprise portal. Refer to Portal for ArcGIS: Import licenses for instructions.

Article ID: 000036187

Software:
  • ArcGIS Pro
  • Portal for ArcGIS
  • ArcGIS Enterprise

Receive notifications and find solutions for new or common issues

Get summarized answers and video solutions from our new AI chatbot.

Download the Esri Support App

Get help from ArcGIS experts

Contact technical support

Download the Esri Support App

Go to download options