Error Message
When attempting to log in to ArcGIS Pro with an organizational account, the following error message is returned:
Error:
An unknown error has occurred. Contact your administrator to check that the license manager is running with valid licenses.
Cause
- An incorrect ArcGIS Online or Portal for ArcGIS URLs are stored in the system registry.
- The ArcGIS License Manager machine's MAC address and/or IP address has changes.
- An incorrect ArcGIS License Manager IP address is used for connection.
- Incorrect ports are used to connect to ArcGIS License Manager
- A firewall is not configured to allow connections to ArcGIS License Manager.
Solution or Workaround
Update and specify the correct URL address in Windows Registry Editor
Warning:
The instructions below include making changes to essential parts of the operating system. Esri recommends performing a backup of the operating system and files, including the registry, before proceeding.
Esri cannot guarantee results from incorrect modifications while following these instructions. Exercise caution. Consult a qualified computer systems professional if necessary.
- Close all the ArcGIS applications on the machine.
- Open the Windows Start menu.
- In the search bar, type regedit and press Enter. If prompted, click Yes in the User Account Control window.
- In the Registry Editor window, expand HKEY_CURRENT_USER > Software > ESRI > ArcGIS Online for Pro > SignIn.
- In the SignIn folder, update the URL values for HomeServerURIFile and AuthorizationPortal to direct to the correct ArcGIS Online or Portal for ArcGIS URL addresses.
- Open ArcGIS Pro, and log in with the organizational account.
Recover the license in MyEsri if the machine's MAC address changes
Clear the trusted storage for the licenses and recover the lost licenses in My Esri. Refer to How To: Clear or delete trusted storage for concurrent-use and single-use licenses for steps.
Connect to ArcGIS License Manager via a port
ArcGIS License Manager can run on ports 27000 to 27009. Other programs may interfere with the connection if the same port is used, preventing ArcGIS Administrator from connecting to ArcGIS License Manager. To prevent this, connect to ArcGIS License Manager via a specific port.
- Launch ArcGIS Administrator on the client machine.
- Click Desktop in the left pane of ArcGIS Administrator. Click Change in the right pane.
- Type in the hostname and the port number in the following format: 'port@hostname'. Click OK.
Modify the service.txt file
By default, the service.txt file does not denote a specific port for ArcGIS License Manager to use. Editing this file locks ArcGIS License Manager to a specific unused port.
- Navigate to the following directory and open service.txt on the host machine.
C:\Program Files\ArcGIS\License10.x\bin
- By default, the contents of the file are as shown below:
SERVER this_host ANY
VENDOR ARCGIS
FEATURE ACT ARCGIS 1 permanent 1 7ED49106D630
- Edit the contents of the file as shown below:
SERVER this_host ANY 27000
VENDOR ARCGIS port=27004
FEATURE ACT ARCGIS 1 permanent 1 7ED49106D630
Note:
Any value between 27000 and 27009 can be used for VENDOR ARCGIS PORT.
- Save the service.txt file.
- Connect to ArcGIS License Manager via ArcGIS Administrator.
Configure the firewall
Firewall configurations may prevent ArcGIS License Manager from receiving and making connections. The firewall must be configured to allow ArcGIS License Manager to work through it.
- Navigate to Control Panel > Windows Firewall > Advanced Settings.
- Click Inbound Rules in the left pane.
- Click New Rule in the right pane. The New Inbound Rule wizard runs.
- Select Program > Next.
- Check This program path. Navigate to the following directory by selecting lmgrd.exe > Open > Next:
C:\Program Files\ArcGIS\License10.x\bin
- Select Allow the connection > Next.
- Check the check boxes of all the available options and click Next.
- Name the rule (for example, ArcGIS License Manager) and click Finish.
- Repeat the same steps for the ARCGIS.exe and LSAdmin.exe files. Both files are stored in the same location specified in Step 5.
- Repeat the 'Configuring the firewall' process for Outbound Rules.