Description
In Portal for ArcGIS, when attempting to create an application or make a copy of an existing application, the process stalls indefinitely. In some cases, despite the stalled process, the application is still created when the process is terminated. However, the resulting application cannot be deleted using the portal's administrator credentials within the Portal Home site.
Cause
Certain portal indexes are corrupted, which prevents the indexes from synchronizing with the latest changes.
Solution or Workaround
- Delete the created application from the Portal Sharing Rest page.
- Navigate to the Portal Sharing Rest page and log in with administrator credentials using the following URL:
https://<portal_domain>.com/<portal_webadaptor_name>/sharing/rest
- Navigate to Related Resources > User Content.
- Locate and select the item that requires deletion.
- On the User Item page, scroll down and verify if the Protected parameter is set to false.
Note:
If the Protected parameter is set to true, navigate to Supported Operations and click Unprotect. On the Unprotect Item page, select an appropriate format and click Unprotect Item.
- Click Can Delete Item.
- On the Can Delete Item page, click Can Delete Item? and verify it returns 'true'.
- Navigate back to the User Item page and click Delete Item.
- On the Delete Item page, check the Force deletion? checkbox, select an appropriate format and click Delete Item.
- Perform a full reindex from Portal Admin.
- Navigate to the Portal Administrator Directory as an administrator using the following URL:
https://<machine_name>.<domain_name>.com/webadaptor/portaladmin
- Navigate to System > Indexer > Reindex.
- For Mode, select Full from the drop-down list.
- For Format, select a response format from the drop-down list.
- Click Reindex.