Description
In some instances, after authorizing Mapping and Charting Solutions and the related extensions, some extensions are shown as authorized but not installed. In the example image below, the ArcGIS Desktop Advanced (Single Use) license shows some Mapping and Charting Solutions' software extensions as authorized but not installed in the ArcGIS Administrator window.
Cause
Mapping and Charting Solutions for Desktop is not installed on the machine. ArcGIS Desktop has a dedicated installer for the build version.
Solution or Workaround
Follow the workflow below to install the Mapping and Charting Solutions extensions for ArcGIS Desktop.
- In My Esri, under My Organizations, click Downloads.
- Refer to Step 5 of How To: Download and install Esri software from My Esri for the guide to select and download the Mapping and Charting Solutions for Desktop installation file.
- Launch the downloaded Mapping and Charting Solutions for Desktop installation file to open the program window. Click Browse to select the destination folder of the package download, and click Next >.
- Ensure Launch the setup program. is checked, and click Close. Click Yes when prompted to allow the app to make changes to the machine.
- In the Welcome to the Mapping and Charting Solutions <version number> for Desktop Setup Programs window, click Next >.
- In the Master Agreement window, check the I accept the master agreement checkbox, and click Next >.
- In the Product Selection window, do the following:
- For Production Mapping, click Task Assistant Manager.
- Click the drop-down next to the icon of the desired extension to install, and select This product will be installed on local hard drive.. Do this for all the extensions.
- Click Next >.
- In the Ready to Install the Program window, click Install.
- Click Finish to complete the installation.
- Ensure the extensions are displayed as installed in the ArcGIS Administrator window. The image below shows all the related extensions installed and authorized.