PROBLEM

The map's legend is not displayed when using a custom print service in Portal for ArcGIS

Last Published: June 29, 2023

Description

When attempting to print a custom layout using a custom print service in Portal for ArcGIS, the map's legend is not displayed, as shown in the map image below.

A layout displaying a map with unique point features and a scale bar with no legend.

Cause

The legend printing capability for each custom print template is disabled by default in Portal for ArcGIS.

Solution or Workaround

For Classic Map Viewer:

  1. Log in to Portal for ArcGIS using an administrator account.
  2. Click Organization > Settings.
  3. On the left side of the Settings page, select Utility services.
  4. In the Printing section, browse to the print template, click More Options The More Options icon., and select Edit.
The list of print templates displayed in the Printing section.
  1. In the Update Print Template window, check the Print Legend check box.
  2. Click Update.
The Update Print Template window to be updated.

The map image below shows the legend displayed when using the custom print service in Portal for ArcGIS.

The map displaying the legend and a scale bar.
 

For Map Viewer and ArcGIS Experience Builder:

In these applications, the option to include the legend is available as a checkbox in the Advanced properties section of the print widget, as shown in the next two images:

Example of where to check once the Advanced properties section is expanded: 

Map Viewer

Advanced print options in Map Viewer

Experience Builder

Advanced print options in Experience Builder

Article ID: 000027368

Software:
  • Portal for ArcGIS
  • ArcGIS Experience Builder

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