PROBLEM

Survey results are not updated in ArcGIS Survey123

Last Published: March 8, 2023

Description

After making edits and republishing a survey form in ArcGIS Survey123 Connect, the updated survey form and results are not displayed in the "results" (formerly named "stakeholder") view in ArcGIS Online or Portal for ArcGIS, and the survey results are not updated in the user account in ArcGIS Survey123, but appear in the publisher account in ArcGIS Survey123.

Note:
The SurveyName_form and SurveyName_results hosted feature layer views were named SurveyName_fieldworker and SurveyName_stakeholder, respectively in earlier versions of Survey123.

The image below shows the updated survey form and results are not updated in the results view in ArcGIS Online or Portal for ArcGIS.

Old Stakeholder View in ArcGIS Online.

The image of the republished feature service below shows the updated feature service in ArcGIS Online or Portal for ArcGIS.

Updated feature service in ArcGIS Online.

The image below shows the survey results are not updated in the user account in ArcGIS Survey123.

User account view in Survey123 for ArcGIS.

The image below shows the survey results are updated in the publisher account in ArcGIS Survey123.

Publisher account view in Survey123 for ArcGIS.

Cause

When republishing a survey from ArcGIS Survey123 Connect, a new hosted feature layer of the survey is generated in the survey folder (Survey-SurveyName) in ArcGIS Online or Portal for ArcGIS, but the results feature layer view (SurveyName_results) still references the old feature layer of the survey. The viewing permission in ArcGIS Survey123 still references the previously configured sharing settings of the results feature layer view.

Solution or Workaround

To circumvent this issue, the publisher of the survey must modify the sharing settings of the survey in ArcGIS Survey123 to generate an updated version of the results feature layer view.

  1. In ArcGIS Online or Portal for ArcGIS, delete the existing results feature layer view (SurveyName_results) in the survey folder (Survey-SurveyName).
Note:
Deleting the _result view and re-sharing the survey results is just a workaround to fix this issue in Survey123 Connect, it is recommended not to delete the _form or _results view by any other means.

For more details, see Share surveys topic and Share results topic.
  1. In ArcGIS Survey123, unshare the republished survey to users. Refer to ArcGIS Survey123: Share a survey.
    1. Click the Share survey pane. Under Who can submit data to this survey?, uncheck all the check boxes of all the options and click Save.
    2. Click the Share results pane. Under Who can view results of this survey?, uncheck all the check boxes of all the options and click Save.
  2. Share the survey once more to users in ArcGIS Survey123.
    1. Click the Share survey pane. Under Who can submit data to this survey?, check the check boxes of the desired options and click Save.
    2. Click the Share results pane. Under Who can view results of this survey?, check the check boxes of the desired options and click Save.

The results feature layer view references the feature service of the republished survey, and users are able to see the updated survey results in ArcGIS Survey123.

Note:
Users must delete the earlier version of the downloaded survey form in the ArcGIS Survey123 field app and re-download the updated survey form before filling the survey questions to ensure the correct version is used.

Article ID: 000016667

Software:
  • ArcGIS Survey123 Connect
  • ArcGIS Survey123 Website

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