Description
When publishing a survey in ArcGIS Survey123 Connect to ArcGIS Online or the ArcGIS Enterprise portal, the process loads but does not complete, stopping at 'Creating form item,' as shown in the image below.
Cause
- The XLSForm with the same name is used across multiple surveys. Using the same XLSForm name in multiple surveys causes issues because each survey must have a unique form ID.
- The XLSForm contains large file sizes in the media folder. A high volume of image files, audio files, or large custom basemap files results in issues during publishing.
Solution or Workaround
Save the XLSForm with a different name before creating a new survey
- On the local machine, navigate to the survey folder located at:
C:\Users\<username\ArcGIS\My Survey Designs\<survey_title>
- Rename and save the XLSForm of the survey. Ensure no surveys or feature layers with the same name in ArcGIS Online or the ArcGIS Enterprise portal.
- Create a new survey using the XLSForm.
- In ArcGIS Survey123 Connect, click New survey.
- Sign in to the ArcGIS organization.
- For Title, specify a title for the new survey.
- For Create a new survey form, select the File option.
- For XLSForm file, click Select, browse for and select the XLSForm saved in Step 1.
- Click Create survey.
- Click the Publish button to publish the new survey.
Remove the large file from the survey's media folder
- Open the survey in ArcGIS Survey123 Connect and click the Media tab.
- Click Open media folder, navigate to the item, and delete the item.
Alternatively, directly delete the item from the media folder on the local machine located at:
C:\Users\<username>\ArcGIS\My Survey Designs\<survey_title>\media