PROBLEM

Portal for ArcGIS: 3D scene layers and hosted feature layers do not load in maps and apps

Last Published: January 24, 2025

Description

When attempting to load 3D scene layers and hosted feature layers in Portal for ArcGIS maps and apps, the process fails without an error message.

Additionally, ArcGIS Pro fails to publish services to ArcGIS Enterprise.

Cause

  • The permissions for the ArcGIS Server service account on the directories and config-store folders have been reset.
  • ArcGIS Data Store is not validated successfully.

Solution or Workaround

Based on the cause, use one of the following workflows:

Restore permissions for the ArcGIS Server account

Run the Configure ArcGIS Server Account utility to restore the permissions for the ArcGIS Server account on the directories and config-store folders. Refer to ArcGIS Server: Configure ArcGIS Server Account utility for additional information.

Re-register and validate ArcGIS Data Store

  1. Unregister ArcGIS Data Store. Refer to Portal for ArcGIS: unregisterdatastore for additional information.
  2. Register ArcGIS Data Store. Refer to Portal for ArcGIS: registerdatastore for additional information.
  3. Validate ArcGIS Data Store. Refer to How To: Validate ArcGIS Data Store for instructions.

Article ID: 000033117

Software:
  • ArcGIS Data Store
  • Portal for ArcGIS
  • ArcGIS Server
  • ArcGIS Enterprise 11 3
  • ArcGIS Enterprise 11 2
  • ArcGIS Enterprise 11 4

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