Description
When clicking or hovering over a feature in the ArcGIS Instant Apps Basic (Media Map) template, the pop-up window docks to the full screen on mobile devices. This limits map visibility and makes it difficult for users to interact with other features or navigate the map.
The image below shows the pop-up window is docked in the ArcGIS Instant Apps on a mobile device.
Cause
- By default, pop-ups on mobile devices are designed to dock to the full screen for increased readability. In portrait mode, this docked pop-up may appear to crop or overlap the map, limiting visibility.
- The 'Enable hover pop-up' option is toggled on. After the pop-up is docked and closed, hovering over the feature again keeps the pop-up docked, and the Undock icon becomes unavailable. The pop-up then remains docked to the full screen on the mobile device.
Solution or Workaround
- Log in to ArcGIS Instant Apps and click the My Apps tab.
- Browse to the app and click Configure.
- In the configuration panel, toggle Express off to access the full configuration settings of the app.
- In the Turn off express mode window, click Continue.
- Click Interactivity > Explore/navigate.
- Toggle Fixed pop-up location on. Optionally, expand the Pop-up position drop-down menu and select the preferred position.
Note:
Optionally, click Search settings on the side panel, search for and click Fixed pop-up location.
The image below shows the pop-up undocked at a fixed location on the mobile device.