PROBLEM

Missing UMN ID in ArcGIS Administrator after upgrading ArcGIS Desktop

Last Published: January 1, 2021

Description

When upgrading ArcGIS Desktop, the upgrade process fails, returning no error messages. Launching ArcGIS Administrator and navigating to the machine details window displays missing UMN IDs. A machine's UMN ID is important information, as it is used to facilitate the recovery of lost licenses, and to create Esri Secure License Files (ESLF)

Cause

When upgrading ArcGIS Desktop, the installer stops the FNPLicensingService to allow the installation to proceed smoothly. However, when FNPLicensingService is in use by other third-party software, the installer is prevented from stopping the service. This prevents the installer from upgrading ArcGIS Desktop and FNPLicensingService.

Solution or Workaround

Uninstall ArcGIS Desktop, and stop FNPLicensingService before reinstalling the software.

Note:
Stopping the service may affect other programs utilizing it. Ensure all other programs are closed before performing the following workaround.
  1. Launch Windows Control Panel, and select Programs and Features.
  2. Right-click ArcGIS Desktop, and select Uninstall. Follow the on-screen instructions to complete the uninstall process.
  3. Launch Windows Services, and search for FlextNet Licensing Service and FlexNet Licensing Service 64.
  4. Right-click each service, and select Properties.
  5. In the FlextNet Licensing Service Properties and FlexNet Licensing Service 64 Properties windows, click Stop to stop the services.
  6. Reinstall the latest version of ArcGIS Desktop.
  7. Launch Windows Services, and search for FlextNet Licensing Service and FlexNet Licensing Service 64.
  8. Right-click each service, and select Properties.
  9. In the FlextNet Licensing Service Properties and FlexNet Licensing Service 64 Properties windows, click Start to start the services.

Article ID: 000013378

Software:
  • ArcMap

Receive notifications and find solutions for new or common issues

Get summarized answers and video solutions from our new AI chatbot.

Download the Esri Support App

Related Information

Discover more on this topic

Get help from ArcGIS experts

Contact technical support

Download the Esri Support App

Go to download options