PROBLEM

java.exe processes missing in Windows Task Manager and access to ArcGIS Enterprise portal disabled via ArcGIS Web Adaptor URL

Last Published: April 24, 2025

Description

Attempting to open the ArcGIS Enterprise portal through the ArcGIS Web Adaptor URL fails. While monitoring the Windows Task Manager, the java.exe process is not present, although javaw.exe and multiple postgresql.exe processes are running as expected. The page returns the following error:

Error: 
Could not access any ArcGIS Enterprise portal machines. Please contact your system administrator.
The error message

For more information regarding the error message, refer to Error: Could not access any Portal machines. Please contact your system administrator. Although accessing the ArcGIS Enterprise portal through the Web Adaptor URL fails, the ArcGIS Portal Administrator Directory remains accessible through the direct URL below:

https://portal.domain.com:7443/portaladmin

Cause

The portal index is corrupted in the ArcGIS Portal Administrator Directory, displaying zero for all values in the 'Count in index' column, as shown in the image below.

The corrupted index count in the Portal Administrator Directory

Solution or Workaround

Run the reconfigure operation to fix the corrupted index.

  1. Log in to the ArcGIS Portal Administrator Directory with administrator credentials.
  2. Navigate to Home > System > Indexer and click Reconfigure.

The Index Status below shows that the value in the 'Count in index' column matches the value in the 'Count in store' column. After the index is fixed, the java.exe process runs in Windows Task Manager, and the portal becomes accessible through the ArcGIS Web Adaptor URL.

The fixed index count in the Portal Administrator Directory

Article ID: 000034745

Software:
  • Portal for ArcGIS
  • ArcGIS Enterprise

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