PROBLEM

Error "00290: Cannot connect through admin URL or services URL" while publishing to ArcGIS Server from ArcGIS Pro

Last Published: September 10, 2020

Description

When publishing services from ArcGIS Pro to a federated server, the following error message is returned:

Error:   
00290: Cannot connect through admin URL or services URL.

Cause

This error occurs when the client machine or the publisher machine is unable to access the Admin API through the Admin URL or services URL. Refer to 00290: Cannot connect through admin URL or services URL for more information.

Solution or Workaround

The following workaround helps resolve this error:

  1. Capture the web traffic while publishing the web layer from ArcGIS Pro, and query the Debug log level in ArcGIS Server Manager to understand the underlying point of failure. Refer to ArcGIS Server: Work with server logs for more information.
  2. Check the server validation to verify the Admin URL and Server URL. To do so:
    1. Log in to Portal Administrator Directory. Navigate to Federation > Servers.
    2. Select the hosted server, and click Validate.
  3. The admin URL is not accessible from the client machine. This occurs if the admin URL used when federating ArcGIS Server with Portal for ArcGIS is over an internal machine URL instead of a DNS alias. Follow the steps below to access the admin URL.
Note:
The Administration URL setting must be a URL the portal can use to communicate with all servers on the site. Refer to Portal for ArcGIS: Federate an ArcGIS Server site with your portal for more information.
  1. Log in to ArcGIS Portal Sharing REST Directory. Navigate to Portals > Self > Users.
  2. In the Users page, click Org ID.
  3. In the Child Resources section, click Servers.
  4. Click Server Id > Update Server to update to a URL accessible from client machines, where publishing is done. For example, https://DNSAlias:6443/arcgis or https://webadaptorhost.domain.com/webadaptorname.
  5. Click Update.
Image of Update Server in ArcGIS Protal Directory
  1. Check if the ArcGIS Web Adaptor is registered with the Server URL, and Administrative Access is enabled.
    1. Log in to ArcGIS Server Manager. Navigate to Site > Web Adaptors.
    2. Ensure ArcGIS Web Adaptor is configured with the federated server, and Administrative Access is enabled.
Image of Web Adaptors Registered with ArcGIS Server in ArcGIS Server Manager
  1. ​​If Administrative Access for Web Adaptor is not enabled, follow the steps below.
    1. Log in to ArcGIS Server Manager. Navigate to system > webadaptors.
    2. Click the Web Adaptor ID.
    3. Append '/update' in the URL in the address bar.
    4. Enable the Admin Access Enabled option.
    5. Click Update.
Image of Update Web Adaptor in ArcGIS Server Administrator Directory

Alternatively, enable Administrative Access for Web Adaptor from the Web Adaptor configuration page. Refer to ArcGIS Enterprise: Configuring the Web Adaptor from the configuration web page for more information.

  1. Navigate to the Web Adaptor configuration page for ArcGIS Server. The URL is as follows:
https://webadaptorhost.domain.com/webadaptorname/webadaptor
  1. The ArcGIS Server option is selected if Web Adaptor is configured with the site, and click Next.
  2. Provide the ArcGIS Server URL and the credentials for Administrator.
  3. Check the Enable administrative access to your site through the Web Adaptor option.
  4. Click Configure.
Image of Web Adaptor configuration in ArcGIS Web Adaptor

Article ID: 000023002

Software:
  • Portal for ArcGIS
  • ArcGIS Server

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