PROBLEM

ArcGIS Pro fails to launch even though the service is running

Last Published: July 10, 2024

Description

When attempting to open ArcGIS Pro after its installation, the application fails to open with the splash screen failing to display. However, when viewing the running tasks in Task Manager, the ArcGIS Pro process indicates that it is running in the background as usual.

Cause

The DigiCert Trusted Root G4 and VeriSign Universal Root Certification Authority certificates are not installed on the machine. This issue may occur when ArcGIS Pro is installed in certain environments, such as custom OS builds.

Solution or Workaround

Note: 
If the ArcGIS Pro version is 3.0 and earlier, consider updating it to the latest version. If the issue persists, follow the workaround below.

Identify if the certificates are installed on the machine.

  1. Launch mmc. When prompted, click Yes.
  2. Click the File tab and select Add/Remove Snap-in....
  3. In the Add or Remove Snap-ins window, under Available snap-ins, click Certificates and click Add >.
  4. In the Certificates snap-in window, select Computer Account and click Next > Finish > OK.
  5. Under Console Root, expand Certificates (Local Computer) and expand Trusted Root Certification Authorities. Click Certificates.
  6. On the right menu, search for DigiCert Trusted Root G4 and VeriSign Universal Root Certification Authority.

If the DigiCert Trusted Root G4 and VeriSign Universal Root Certification Authority certificates are not available, contact the organization's IT team to install the certificates on the machine.

Article ID: 000030540

Software:
  • ArcGIS Pro 3 1
  • ArcGIS Pro 3 3
  • ArcGIS Pro 3 0
  • ArcGIS Pro 3 2

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