PROBLEM

A license expiry warning message is returned after renewing an ArcGIS Pro term license

Last Published: April 14, 2021

Description

In some instances, after renewing the term license, a license expiry warning message for ArcGIS Pro and its related extensions are returned when starting ArcGIS Pro.

Warning:   
<ArcGIS Pro software or extension> will expire in <duration>.

The warning message for the ArcGIS Pro software and the related extensions license expiry notification when starting ArcGIS Pro.

Cause

By design, when an ArcGIS Pro term license is renewed, the renewed term does not start until the existing license expires. The warning message displays the existing expiry date instead of the renewed expiry date.

Solution or Workaround

The warning message can be ignored if the license is renewed. Follow the workflow below to check if the license is renewed and the renewed license expiration date.

  1. Log out of My Esri, ArcGIS Online, and ArcGIS Pro.
  2. Open ArcGIS Pro, click Settings The Settings cogwheel icon, and click Licensing.
  3. Check the renewed license expiry date for the ArcGIS software and the related extensions.
The Licensing page with the renewed expiry dates of the ArcGIS Pro software and the related licenses

If the warning message persists, contact a Customer Service Representative to ensure the license renewal is processed. The warning message can be disregarded if the license renewal is confirmed. The new license is effective after the completion of the existing term, and the renewal is automatically updated in the ArcGIS Online subscription.

Article ID: 000024607

Software:
  • ArcGIS Pro 2 7 x
  • ArcGIS Pro 2 x

Receive notifications and find solutions for new or common issues

Get summarized answers and video solutions from our new AI chatbot.

Download the Esri Support App

Related Information

Discover more on this topic

Get help from ArcGIS experts

Contact technical support

Download the Esri Support App

Go to download options