BUG

On Azure, ArcMap stops working after installing ArcGIS Pro

Last Published: August 2, 2023

Description

On the Azure platform, when ArcMap and ArcGIS Pro are installed together, ArcMap stops working after installing ArcGIS Pro version 3.0.3 or higher.

Note:
The issue only occurs on virtual machines in the Microsoft Azure Cloud environment.
  1. Install ArcGIS Desktop (ArcMap) and authorize with a Single Use license. Go to the Availability folder in the ArcGIS Administrator to verify Single Use licenses were successfully authorized.
  2. Start ArcMap. Install ArcGIS Pro 3.0.3 or higher. Proceed to authorize Pro Single Use licenses.
  3. Start ArcGIS Pro. Go back to the Availability folder in the ArcGIS Administrator. 

Notice that the previously authorized Single Use licenses for ArcGIS Desktop are all untrusted. As a result, no ArcGIS Desktop applications can be started.

Cause

ArcMap and ArcGIS Pro use a third-party system for licensing the products, FlexNet Publisher, and use the same trusted storage to store the Single Use licenses. Both applications use the FlexNet Licensing Service to access this trusted storage. However, each application uses its own individual FlexNet Licensing Service, as ArcMap is a 32-bit application and uses FlexNet Publisher 11.18.2.0, and ArcGIS Pro a 64-bit application. At ArcGIS Pro 3.0.3, FlexNet Publisher was upgraded from 11.18.2.0 to 11.18.3.0.

The upgrade to 11.18.3.0 included a change in the FlexNet Licensing Service included with FlexNet Publisher on how it detects and reads the unique machine number (UMN), one of the components used by the trusted storage to identify the machine. The UMN value identified by the later version of the licensing service is different than the previous version. In essence, ArcMap uses one particular UMN and ArcGIS Pro uses a different UMN.

Why is the different UMN value important? When ArcMap Single Use licenses are authorized, the Software Authorization Wizard uses FlexNet Licensing Service version 11.18.2.0 to access the trusted storage and store the ArcMap Single Use licenses. When ArcGIS Pro 3.0.3 and later is subsequently authorized, the ArcGIS Pro Software Authorization Wizard uses FlexNet Licensing Server version 11.18.3.0 or later to access the trusted storage and store the ArcGIS Pro Single Use licenses. Since the ArcMap licenses were authorized with a different UMN value, they have become untrusted with the authorization of ArcGIS Pro. For the same reason, ArcGIS Pro licenses would become untrusted if you authorize ArcMap later.

Of particular note, once the licenses have become untrusted, you cannot reauthorize with the same entitlement because it already exists on the machine. Furthermore, it is not possible to deauthorize the existing licenses because there are no valid Single Use licenses to deauthorize. In such a case, a manual reset of the trusted storage is required.

Workaround

Contact Esri Technical Support, An analyst will assist you through the process to:

  1. Fill out the request to “Recover Lost Licenses”.
  2. Remove all contents in the trusted storage.
  3. Authorize with the new Single Use licenses.

Article ID:000031057

Software:
  • ArcMap
  • ArcGIS Pro 3 1
  • ArcGIS Pro 3 0

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