ERROR

The selected template can't be loaded

Last Published: January 28, 2021

Error Message

In some instances, when attempting to open and edit custom infographic or a report template in ArcGIS Business Analyst Web App, the template does not load, returning the following error message:

Error:
The selected template can't be loaded.

Cause

The infographic or report template used is corrupted.

Solution or Workaround

To resolve this error, assign the ArcGIS Business Analyst Web App license to another organizational member to edit the template. If the issue persists, proceed with the subsequent solution to recreate the template.

Assign the ArcGIS Business Analyst Web App license to another member to edit the template

Note: 
Ensure the user is signed in as an administrator or is a member with administrative privileges to perform the workflow.
Note: 
An ArcGIS Business Analyst Web App license can only be assigned to user types with publisher roles, for example, a Creator or GIS Professional. Unsupported user types are Basic, Editor, Field Worker, Lite, and Viewer.
  1. Share the template with the organization.
    1. Log in to ArcGIS Business Analyst Web App, and open the project.
    2. Click the Reports tab. Click Build Reports > Build Infographics.
    3. Click My templates. Hover the cursor over the desired infographic template, and click the Share template Image showing the Share template icon. icon.
    4. In the Share Report Template window, select Entire organization (organization_name), and click Share.
Image showing the Share Report Template window to select the entire organization option
  1. Log in with another organizational account. Ensure this account has the ArcGIS Business Analyst license assigned. If the account does not have this license, refer to ArcGIS Business Analyst: Manage Licenses for instructions to assign the license.
  2. Perform and save the edits on the template as required with the new organizational account.
  3. Share the template with the organization by repeating Step 1.
  4. Using the original user account, open and save the template as required.

Rebuild the template to replace the corrupted template

Recreate the infographic template.

Article ID: 000024906

Software:
  • ArcGIS Online
  • ArcGIS Business Analyst Web App

Receive notifications and find solutions for new or common issues

Get summarized answers and video solutions from our new AI chatbot.

Download the Esri Support App

Get help from ArcGIS experts

Contact technical support

Download the Esri Support App

Go to download options