ERROR

Portal for ArcGIS: The item you requested cannot be found. The item may have been deleted or you may have entered an incorrect URL

Last Published: May 14, 2024

Error Message

Attempts to open or delete an item in Portal for ArcGIS fail with the following error message returned:

Error:
The item you requested cannot be found. The item may have been deleted or you may have entered an incorrect URL.
The error message returned when attempting to delete an item in Portal for ArcGIS

Cause

The item or its dependent layers are missing or detached. This can happen when the item is deleted directly in the portal item directory or when transferring items from one organization to another.

Solution or Workaround

Performing a reindex can remove items listed in Portal for ArcGIS that are detached. Follow the steps below to do so:

  1. Navigate to the Portal Administrator Directory as an administrator using the following URL:
https://<machine>.<domain>.com/webadaptor/portaladmin
  1. Navigate to System > Indexer > Index Status.
  2. If the Count in store values do not match the Count in index values, navigate to System > Indexer > Reindex.
  3. For Mode, select Full from the drop-down list.
  4. For Format, select a response format from the drop-down list.
  5. Click Reindex.

If the Count in store values do match the Count in index values, consider recreating the item or the affected layers associated with the item. Refer to FAQ: Can deleted items be recovered in ArcGIS Enterprise? for best practices on restoring and republishing deleted items.

Article ID:000032597

Software:
  • Portal for ArcGIS
  • ArcGIS Enterprise 11 0
  • ArcGIS Enterprise 11 2
  • ArcGIS Enterprise 11 1

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