ERROR

Portal for ArcGIS: Failed to rollback. Code 500

Last Published: June 14, 2024

Error Message

In the Portal Administrator Directory, when attempting to restore a site from a backup site configuration file using the importSite operation, the following error message is returned:

Error:   
Failed to rollback. 
Code: 500
The error message, Error Failed to rollback. Code 500 is returned.

Cause

  • The directory path of the backup site configuration file is incorrect or does not exist.
  • The Portal for ArcGIS account does not have permission to access the backup site configuration folder location.

Solution or Workaround

Note: 
The workarounds may require the assistance of the IT team.
Note: 
For Portal for ArcGIS 11.1 and later, ensure the Validate location? check box is checked in the Portal Administrator Directory when restoring the backup using the importSite operation.

For Portal for ArcGIS 11.0 or earlier, use the workarounds provided below.

Ensure the directory path of the backup site configuration file exists and is accurate

Copy the directory path from the path bar in Windows File Explorer and paste it into the parameter box of the importSite operation in the Portal Administrator Directory.

Modify the permission for the configuration file

Set the permission for the folder location where the configuration file is stored for the desired Portal for ArcGIS account.

  1. Log in to the Portal for ArcGIS machine hosting the folder.
  2. Open Windows File Explorer, and navigate to the backup site configuration file folder. Right-click the folder and select Properties.
  3. Click Security > Edit... > Add....
  4. In the Select Users, Computers, Service Accounts, or Groups window, click Locations and select the machine name from the list. For domain accounts, select Entire Directory instead.
  5. Click OK.
  6. Enter the desired account name into the Enter the object names to select text box, and click Check Names.
  7. Click OK.
Note: 
To find the service account running Portal for ArcGIS, run Services on the Portal for ArcGIS machine. Identify the account on the Log On tab in the Portal for ArcGIS Properties (Local Computer) window.

Article ID:000032639

Software:
  • Portal for ArcGIS
  • ArcGIS Enterprise 11 0
  • ArcGIS Enterprise 11 1
  • ArcGIS Enterprise 11 3
  • ArcGIS Enterprise 11 2

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