Error Message
In Portal for ArcGIS, when attempting to update the license from the Portal Administrator Directory > License > Import License, the following errors are returned:
Error:
Failed to configure the definition of the appBundles Essential Apps
Code: 500
Error:
Failed to configure the definition of the appBundles Office Apps
Code: 500
In the Portal logs, the following severe error is returned:
Error:
The server at https://<machine_name>.<domain_name>:7443/arcgis/sharing/rest/portals/configurableAppBundle' returned an error. Invalid app bundle. ["Invalid apps"]
In some instances, the certain pages or tab in Portal for ArcGIS loads indefinitely, thereby preventing full access to the page or tab. The affected pages or tabs are as follows:
- The Organization tab.
- The Members tab.
- The Licenses tab.
- The Settings page.
- The item details page.
The image below shows the example of the Overview tab loading indefinitely.
Cause
Default item file(s) or folder(s) in the portal's content directory is corrupted which results in an issue with reading and updating portal's licenses.
Solution or Workaround
Warning:
The instructions below include making changes to essential parts of the ArcGIS Enterprise deployment and the operating system, which may affect other applications and functionalities on the machine. Esri recommends performing a backup of the ArcGIS Enterprise machine, including the registry, before proceeding.
Esri cannot guarantee results from incorrect modifications while following these instructions and is not responsible for any changes made to the system. Consult a qualified computer systems professional if necessary.
- Navigate to the Portal Administrator Directory, and log in as an administrator using the following URL:
https://<machine_name>.<domain_name>/<web_adaptor_name>/portaladmin
- Run the Export Site operations to create a .portalsite backup file. Refer to ArcGIS REST APIs: Export Site for additional information.
- For the Destination parameter, select a folder path.
- Check the Validate location? check box.
- For the Format parameter, select the response format.
- Click Export Site.
- Perform a clean uninstallation of Portal for ArcGIS. Refer to How To: Perform a clean uninstallation of ArcGIS Enterprise base deployment components for steps.
- Install Portal for ArcGIS. Refer to ArcGIS Enterprise: Installing Portal for ArcGIS for steps.
- Create a new portal site. Refer to ArcGIS Enterprise: Create a single machine portal for steps.
- Stop the Portal for ArcGIS service. Refer to Portal for ArcGIS: Stop and start the portal for steps.
- In File Explorer, navigate to the following directory:
C:\arcgisportal\content\item
- Copy all files in the folder, excluding the following folders:
- Create a temporary folder on the machine and paste the copied files into the newly created temporary folder.
- Start the Portal for ArcGIS service. Refer to Portal for ArcGIS: Stop and start the portal for steps.
- In Portal Administrator Directory, run the Import Site operations to restore the .portalsite backup file created in Step 2. Refer to ArcGIS REST APIs: Import Site for additional information.
- For the Source (File path with extension .portalside) parameter, select the folder path in Step 2a.
- Check the Validate location? check box.
- For the Format parameter, select the response format selected in Step 2c.
- Click Import Site.
- Stop the Portal for ArcGIS service. Refer to Portal for ArcGIS: Stop and start the portal for steps.
- Copy and paste the files from the folder created in Step 9 into the existing portal's content directory. When prompted by the Replace or Skip Files dialog box, select Replace the files in the destination.
- Start the Portal for ArcGIS service. Refer to Portal for ArcGIS: Stop and start the portal for steps.
The image below shows the Overview tab fully loaded.