ERROR

ArcGIS Pro requires Microsoft .NET Desktop Runtime (x64)

Error Message

When updating ArcGIS Pro to version 3.0.0, the following error is returned:

Error:  
ArcGIS Pro requires Microsoft .NET Desktop Runtime (x64). To download and install Microsoft Windows Desktop Runtime - 6.0.5 (x64) or greater, visit the Microsoft Website or contact your system administrator

Cause

ArcGIS Pro version 3.0.0 requires Microsoft .NET Desktop Runtime 6.0.5 or a later patch release (6.0.6, and so on), using a Windows x64 installer. The presence of Microsoft .NET Desktop Runtime 7 or later is inconsequential to ArcGIS Pro 3.0.

Solution or Workaround

Download and install the latest available version of Microsoft .NET 6.x.x Desktop Runtime – Windows x64 from Microsoft: Download .NET 6.0, as shown in the image below.

29200c.png

If the issue persists, it could mean the Microsoft .NET Desktop Runtime 6.x.x installation process did not complete properly and may require reinstallation. Uninstall the the driver in Control Panel and run the installer again.

Article ID:000027925

Software:
  • ArcGIS Pro 3 0

Get help from ArcGIS experts

Contact technical support

Download the Esri Support App

Go to download options

Related Information

Discover more on this topic