ERROR

ArcGIS Pro: Licensing configuration settings are locked. Please contact your organization's administrator

Last Published: August 21, 2024

Error Message

When attempting to launch ArcGIS Pro with a Concurrent Use license, the launch fails and returns the following error message:

Error:
Licensing configuration settings are locked. Please contact your organization's administrator.

In some instances, the error message also returns when attempting to change the license level of the Concurrent Use license in ArcGIS Pro.

Cause

By default, installing ArcGIS Pro silently sets the LOCK_AUTH_SETTING key in the Registry Editor to True. When this parameter is set to true, the license configuration is disabled, and any changes required are blocked. 

Solution or Workaround

Uninstall and reinstall ArcGIS Pro

  1. Perform a clean uninstallation of ArcGIS Pro. Refer to Steps 1 through 6 of How To: Perform a clean uninstall and reinstall of ArcGIS Pro for instructions.
  2. Reboot the system. Refer to Microsoft: Restart (reboot) your PC for instructions.
  3. Reinstall ArcGIS Pro. Refer to ArcGIS Pro: Install ArcGIS Pro for instructions.
Note:
When performing a silent installation of ArcGIS Pro, ensure the LOCK_AUTH_SETTING parameter is set to False. Refer to ArcGIS Pro: Install ArcGIS Pro silently using command line parameters for additional information.

Change the LOCK_AUTH_SETTING key in the Registry Editor

Warning:   
The instructions below include making changes to essential parts of the operating system. Esri recommends backing up the operating system and files, including the registry, before proceeding.

Esri cannot guarantee results from incorrect modifications while following these instructions. Exercise caution. Consult a qualified computer systems professional if necessary.
  1. Click Start on the Windows taskbar or press the Windows key.
  2. In the search bar, type Registry Editor, right-click Registry Editor, and click Run as administrator. If prompted, click Yes in the User Account Control window.
  3. In the Registry Editor window, expand HKEY_LOCAL_MACHINE > SOFTWARE > ESRI > ArcGISPro > Licensing.
  4. Right-click the LOCK_AUTH_SETTINGS string, select Modify....
  5. In the Edit String dialog box, for Value Data, specify False as the key value.
  6. Click OK.

Article ID:000033293

Software:
  • ArcGIS Pro 3 2
  • ArcGIS Pro 3 1
  • ArcGIS Pro 3 3

Receive notifications and find solutions for new or common issues

Get summarized answers and video solutions from our new AI chatbot.

Download the Esri Support App

Related Information

Discover more on this topic

Get help from ArcGIS experts

Contact technical support

Download the Esri Support App

Go to download options