Error Message
When attempting to launch ArcGIS Pro, the process fails and returns the following error:
Error:
Couldn't sign you in
Unknown error occurred. Please try again. If you continue seeing this error please restart ArcGIS Pro.
After closing and relaunching ArcGIS Pro, the application fails to start and returns the same error.
Cause
The ArcGIS Online For Pro registry key in the Registry Editor is corrupted. The registry key is used by ArcGIS Pro to store settings related to the connection and authentication with ArcGIS Online. The registry key typically contains several subkeys, including:
- OAuth, which specifies the default portal URL used for authentication.
- Portals, which contain URLs for different portals that ArcGIS Pro can connect to.
- SignIn, which stores information related to the log-in process, such as the URL of the ArcGIS Online organization.
Solution or Workaround
Warning:
Editing the Windows registry requires administrator privileges on the machine and must only be performed as a last resort. Back up the registry before performing the steps below. Consult a qualified computer systems professional if necessary.
Esri is not liable for incorrect modifications following these instructions.
- Perform a clean uninstallation of ArcGIS Pro. Refer to Steps 1 through 6 of How To: Perform a clean uninstall and reinstall of ArcGIS Pro for instructions.
- Click Start on the Windows taskbar or press the Windows key.
- In the search bar, type Registry Editor, right-click Registry Editor and click Run as administrator. If prompted, click Yes in the User Account Control window.
- In the Registry Editor window, expand HKEY_USERS > S-1-5-21-<unique identifiers> > SOFTWARE > ESRI.
- Right-click the ArcGIS Online For Pro key, select Rename and rename the key to ArcGIS Online For Pro_old.
- In the Registry Editor window, expand HKEY_CURRENT_USER > SOFTWARE > ESRI.
- Right-click the ArcGIS Online For Pro key, select Rename and rename the key to ArcGIS Online For Pro_old.
- Restart the machine. Refer to Microsoft: Restart (reboot) your PC for instructions.
- Install ArcGIS Pro. Refer to ArcGIS Pro: Install ArcGIS Pro for instructions.