ERROR

ArcGIS Notebooks: Notebook not found at the requested URL

Last Published: June 16, 2025

Error Message

After upgrading ArcGIS Pro, the following error is returned when opening ArcGIS Notebooks:

The error message
Error:
Notebook not found at the requested URL. This may be caused by an unsupported proxy configuration, or an invalid Jupyter Notebook server configuration.

Cause

The following are possible causes for the error message:

  • Corrupted or incompatible Jupyter Notebook server configuration
  • Broken Python environment
  • Unsupported proxy or network configuration

Solution or Workaround

Depending on the cause, use one of the workarounds below to resolve the issue:

Fix the corrupted Jupyter Notebook server configuration by resetting or editing the main configuration file

  1. Locate the configuration file.
  2. Open jupyter_notebook_config.py using a text editor.
  3. Remove the following lines:
c.NotebookApp.ip = '0.0.0.0'
c.NotebookApp.port = 8888
  1. Save the file and restart ArcGIS Pro.

Repair the ArcGIS Pro Python environment

If the Python environment is corrupted, repair or upgrade it through ArcGIS Pro’s built-in tools to restore missing or damaged files and ensure compatibility. Refer to ArcGIS Pro: Repair an environment for instructions.

Set an exclusion on proxy settings

An exclusion must be set by the IT department on the proxy settings to prevent localhost:8778 or 127.0.0.1:8778 from being routed through the proxy.

Note: 
If the above workarounds does not resolve the error, uninstall and reinstall ArcGIS Pro. Refer to ArcGIS Pro: Install ArcGIS Pro for instructions.

Article ID: 000034304

Software:
  • ArcGIS Pro

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