ERROR

ArcGIS Monitor: A duplicate was found - Operation cannot proceed

Last Published: November 6, 2024

Error Message

In ArcGIS Monitor, attempting to register ArcGIS Server or Portal for ArcGIS as a component fails and returns the following error message:

Error:
Error: A duplicate was found - operation cannot proceed
The 'A duplicate was found - operation cannot proceed' error message.

Cause

  • Registering ArcGIS Monitor with an existing registration component which has the same name or identifier.
  • Registering Portal for ArcGIS on a standby machine.

Solution or Workaround

For ArcGIS Server

In the ArcGIS Server Administrator Directory, delete the monitorSystemId property to remove any existing connection from ArcGIS Monitor.

  1. Log in to the ArcGIS Server Administrator Directory with an administrator account using the following URL:
<machine>.<domain>.com/<webadaptorname>/admin
  1. Click system.
  2. For Resources, click properties.
The System page in the ArcGIS Server Administrator Directory.
  1. On the System Properties page, click update.
  2. On the Update Server Properties page, remove monitorSystemId and click Update.

The second option is to delete the usage report in ArcGIS Server Administrator Directory.

  1. Log in to the ArcGIS Server Administrator Directory with an administrator account, and click usagereports.
  2. Click a usage report.
  3. On the Usage Reports - <name> page, click delete.
  4. On the Delete Report page, click Delete.
The Usage Report page in the ArcGIS Server Administrator Directory.

For Portal for ArcGIS

This is expected behavior when registering a highly available Portal for ArcGIS with ArcGIS Monitor. If Portal for ArcGIS is already registered on the primary machine, it cannot be registered again on the standby machine.

Article ID: 000033964

Software:
  • ArcGIS Monitor Server 10 6
  • Portal for ArcGIS
  • ArcGIS Server
  • ArcGIS Enterprise 11 1
  • ArcGIS Enterprise 11 3
  • ArcGIS Enterprise 11 2
  • ArcGIS Monitor Server 10 7

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