Error Message
When authorizing an ArcGIS Desktop single-use license, the following error message is returned:
Error:
All requested features have already been authorized on this machine.
Cause
This error is returned when the selected product is already authorized on the machine or if the license file is corrupt.
Solution or Workaround
Depending on the cause, there are two possible methods to resolve this issue.
Determine if the product is authorized via ArcGIS Administrator
- Launch ArcGIS Administrator.
- On the left pane, click Desktop. Ensure the correct Single Use product is selected.
- Click Availability. On the right pane, check if the product is authorized. If the product is authorized, it is not necessary to authorize it again. If the product is not authorized, the license file may be corrupted.
Remove corrupted license files
Corrupted license files on the affected machine must be removed before the software can be reauthorized.
- Clear the machine's trusted storage. To do so, refer to How To: Clear of delete trusted storage for concurrent-use and single-use licenses.
- Launch ArcGIS Administrator.
- Authorize ArcGIS Desktop with a single-use license. To do so, refer to Authorizing ArcGIS single use products and features.