Error Message
Authorizing or deauthorizing an ArcGIS Desktop license returns the following error:
Error 7284: Cannot perform support actions on inactive fulfillment record <FID number>. [Incident# <Incident number>]
Cause
There are multiple causes for the error, all of which are listed below:
- The ArcGIS Desktop license was not deauthorized prior to uninstalling the software.
- The license activation limit is reached.
- The deauthorization process was interrupted, corrupting the FlexNet Publisher Trusted Storage cache.
- The ArcGIS Desktop license is disabled.
Solution or Workaround
To resolve this issue, clear the FlexNet Publisher Trusted Storage cache by running the ArcGIS Deauthorization Tool or manually clear the files. Steps for both options are provided below:
Deauthorize using ArcGIS Deauthorization Tool
ArcGIS Deauthorization Tool allows users to deauthorize licenses after ArcGIS Desktop is uninstalled from a machine.
- Download ArcGIS Deauthorization Tool.
- Extract the tool from the ZIP file to a temporary location on the local machine. Run the Deauthorize.bat file to deauthorize the licenses.
- Navigate to the following folder and confirm there are no ArcGIS license files:
C:\ProgramData\FLEXnet
Note:
Alternatively, reinstall ArcGIS Desktop and launch ArcGIS Administrator. Select the Availability folder and view the Authorized column. The values here show No if the licenses were successfully deauthorized. Visit My Esri after 24 hours to view the updated license availability.
Remove license files manually
Note:
Perform step one if ArcGIS License Manager is installed. If not, skip to step two.
- Launch ArcGIS License Manager and select Start/Stop License Service in the left pane. Click Stop > Apply > OK in the right pane.
- Remove all ArcGIS files in the following location:
C:\ProgramData\FLEXnet
- Recover the removed licenses via My Esri's Recover Lost Licenses function. Refer to How To: Recover lost licenses from My Esri.
Removed licenses can now be authorized on new machines.