ERROR

Error writing to file: C:\ArcGIS\Pro\bin\ArcGIS.Core.dll. Verify that you have access to that directory

Last Published: October 7, 2024

Error Message

When running the patch file to upgrade ArcGIS Pro, the following error is returned:

Error 1310:
Error writing to file: C:\ArcGIS\Pro\bin\ArcGIS.Core.dll. Verify that you have access to that directory.

Error 1310 dialog box

Cause

There are several possible causes. Different scenarios indicate that the error is likely due to the installation or upgrade process requiring administrative privileges to write to specific directories.

Solution or Workaround

Even if the user is logged in as an administrator, certain installer operations are performed in the system context, which might require explicit permission settings. To address this, please follow these steps:

  1. Open an elevated Command Prompt, right-click the Start Menu icon and select Windows PowerShell (Admin).
    (Windows Terminal can also be used if it is installed.)
Note:
Running the .msp file in the elevated PowerShell bypasses potential file access issues that might arise from restricted permissions on certain system directories.
  1. Run the installation file; click the Yes button in the User Account Control dialog to allow changes to the device.

UAC prompt

  1. In the Command Prompt, navigate to the directory where the install file is located.
  2. Run the installation file. This file has the extension .msp.

    Running .msp file

    Article ID: 000033325

    Software:
    • ArcGIS Pro 3 3

    Receive notifications and find solutions for new or common issues

    Get summarized answers and video solutions from our new AI chatbot.

    Download the Esri Support App

    Related Information

    Discover more on this topic

    Get help from ArcGIS experts

    Contact technical support

    Download the Esri Support App

    Go to download options