ERROR

Error 1304. Error writing to file...Verify that you have access to that directory

Last Published: April 25, 2020

Error Message

When installing ArcGIS products, the following error is returned:

Error:   
Error 1304. Error writing to file...Verify that you have access to that directory.
Screenshot of error 1304 when installing ArcGIS Desktop 10.7

Cause

There are several possible causes for the error when installing ArcGIS products:

  • The user has no access to the directory required for installation on the machine.
  • The installation file is detected as a security threat by the anti-virus software in the machine.
  • The required Microsoft .NET Framework is not installed or working properly in the machine.

Solution or Workaround

Use the following solutions, depending on the ArcGIS product being installed:

ArcMap or ArcGIS Pro
  • Run the installer file as an administrator of the machine. Contact the IT Department for administrator rights.
  • Disable the anti-virus software before installing.
Mapping and Charting Solutions
  • Ensure the proper version of Microsoft .NET Framework is installed on the machine. For more information, refer to Mapping and Charting Solutions install guide: Minimum system requirements.
  • If the proper version of Microsoft .NET Framework is installed, repair Microsoft .NET Framework.
    1. Navigate to Control Panel > Programs > Programs and Features.
    2. Select Microsoft .NET Framework.
    3. Click Change.
    4. Click Repair. Complete the process and click Close.
    5. Install Mapping and Charting Solutions.

Article ID:000021786

Software:
  • ArcMap
  • ArcGIS Pro 2 x

Receive notifications and find solutions for new or common issues

Get summarized answers and video solutions from our new AI chatbot.

Download the Esri Support App

Related Information

Discover more on this topic

Get help from ArcGIS experts

Contact technical support

Download the Esri Support App

Go to download options