BUG

Failures on the standby machine in highly available environments after installing Portal for ArcGIS 11.1 Enterprise Sites Security Patch A or B

Last Published: May 6, 2024

Description

After installing the Portal for ArcGIS 11.1 Enterprise Sites Security Patch A or B, any requests to create content will fail for the standby machine in a highly available Portal for ArcGIS environment.

The 10.8.1 and 10.9.1 versions of the ArcGIS Enterprise Sites Security Patch do not cause this problem.

Cause

The file with the database connection information on the standby machine in a highly available environment has been overwritten and thus reverted to default settings, and the loss of the configured values results in failures on the standby machine.

Workaround

Uninstalling the patch will not resolve the problem. Instead, follow these steps to ensure the correct values are re-applied to the affected file.

  1. In the portal highly available environment where the Portal for ArcGIS 11.1 Enterprise Sites Security Patch A or B has been installed, unregister the standby machine.
  2. Proceed to re-register your standby machine.
  3. The correct values are now added to the file used for database connections on the standby machine.

Esri released a corrected version of the Portal for ArcGIS 11.1 Enterprise Sites Security Patch as of December 12, 2023. The corrected version is identified with a "C" version suffix. This corrected patch ensures new installations do not encounter the bug described in this article. For those who had already installed the Portal for ArcGIS 11.1 Enterprise Sites Security Patch A or B, the correct patch cannot resolve the bug. Instead refer to the steps in this article for a resolution.

Article ID:000031314

Software:
  • Portal for ArcGIS
  • ArcGIS Enterprise 11 1

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