ERROR

ArcGIS Experience Builder applications with the Business Analyst widget fail to load with a deprecated data source error

Last Published: July 5, 2024

Error Message

When using an older version of the Experience Builder app that uses the Business Analyst widget, you may encounter a warning message similar to the following if the widget uses a data source that was deprecated and is no longer available:

Error:
This Business Analyst widget is configured with a data source that has been deprecated. Please update to the latest data sources available.

Cause

Experience Builder applications created with older US demographic data sources must be updated to use an available data source. 

Older vintages of US demographic data, from 2021 and 2022, were deprecated and removed with the June 2024 ArcGIS Online update.  This release contains Esri Updated Demographics for 2024 and 2023 only. Details on this may be found in the deprecation notice.  Details about the deprecation of this data are also available in this blog article.

If you have an application that used 2023 data, it will continue to work until this dataset is retired in 2025.

Solution or Workaround

  1. Open the application in builder mode.
  2. If your Experience Builder widget is configured to use United States, set the data source to Esri 2024.
  3. If Preset mode is selected, select the default infographic and make additional configuration as needed.
  4. If you are using Workflow mode, click Customize infographics and select the list of infographics.
  5. Save and re-publish the application.

Article ID:000033010

Receive notifications and find solutions for new or common issues

Get summarized answers and video solutions from our new AI chatbot.

Download the Esri Support App

Related Information

Discover more on this topic

Get help from ArcGIS experts

Contact technical support

Download the Esri Support App

Go to download options