ERROR

Das Portal wurde initialisiert und konfiguriert, ist jedoch nicht zugänglich. Die interne Portal-Datenbank wird offenbar nicht ausgeführt oder akzeptiert keine Verbindungen.

Last Published: October 1, 2021

Fehlermeldung

Kein Zugriff auf die Startseite des Portals möglich mit der folgenden schwerwiegenden Fehlermeldung in den Portal-Protokollen:

Error: Das Portal wurde initialisiert und konfiguriert, ist jedoch nicht zugänglich. Die interne Portal-Datenbank wird offenbar nicht ausgeführt oder akzeptiert keine Verbindungen.

Diese Fehlermeldung wird in den folgenden Szenarien zurückgegeben:

  • Es wurde auf ein Upgrade auf eine neuere Version von Portal for ArcGIS durchgeführt.
  • Das Portal wurde neugestartet.
  • Der Server wurde nicht korrekt heruntergefahren. Zum Beispiel während eines Stromausfalls.
  • Nach einem fehlerhaften Versuch, Inhalte auf dem Portal for ArcGIS zu veröffentlichen.

Ursache

  • Das Portal for ArcGIS kann nicht auf den Data Store zugreifen, da der Data Store sich wegen zu wenig Speicherplatz im schreibgeschützten Modus befindet.
  • Nicht genügend Arbeitsspeicher auf dem Portal-Computer. Weitere Informationen finden Sie unter Portal for ArcGIS: Hardwareanforderungen.
  • Das Service-Konto, das bei der Konfigurierung von Portal for ArcGIS angegeben wurde, stimmt nicht mit dem Service-Konto überein, das bei der Konfigurierung von ArcGIS-Server und ArcGIS Data Store angegeben wurde. Alle Komponenten von ArcGIS Enterprise müssen dasselbe Service-Konto verwenden.
  • Portal for ArcGIS wurde nicht korrekt konfiguriert oder verbunden.

Lösung oder Problemumgehung

Verwenden Sie je nach Ursache des Problems eine der folgenden Problemlösungen:

Sicherstellen, dass ausreichend Festplattenspeicher und Arbeitsspeicher auf dem Portal-Computer zur Verfügung stehen

  1. Vergrößern Sie den Speicherplatz des ArcGIS Data-Store-Computers. Weitere Informationen finden Sie unter ArcGIS Enterprise: Erforderlicher Speicherplatz.
  2. Versetzen Sie den Data Store vom Typ "relational" vom schreibgeschützten Modus in den Lese-/Schreibmodus. Weitere Informationen hierzu finden Sie im Abschnitt zur Lösung im Artikel Error: Neue Features konnten nicht erstellt werden. Allgemeiner Funktionsfehler [Es ist ein Datenbankfehler aufgetreten.].

Portal for ArcGIS so konfigurieren, dass sie dasselbe Service-Konto verwenden wie ArcGIS-Server und ArcGIS Data Store

Portal for ArcGIS, ArcGIS-Server und ArcGIS Data Store können so konfiguriert werden, dass sie entweder ein Domänenkonto, ein lokales Konto oder ein verwaltetes Service-Konto (gMSA) verwenden. Für alle Komponenten in ArcGIS Enterprise muss derselbe Service-Kontotyp verwendet werden.

Informationen dazu, wie Sie das verwendete Service-Konto in Portal for ArcGIS ändern, finden Sie unter ArcGIS Enterprise: Ändern des Portal for ArcGIS-Kontos.

Informationen dazu, wie Sie das verwendete Service-Konto in ArcGIS-Server ändern, finden Sie unter ArcGIS Enterprise: Ändern des ArcGIS Server-Kontos.

Informationen dazu, wie Sie das verwendete Service-Konto in ArcGIS Data Store ändern, finden Sie unter Portal for ArcGIS: ArcGIS Data Store Konto.

Wiederherstellen des Portals auf eine vorherige laufende Instanz mit dem Backup-Werkzeug "webgisdr"

Eine vorherige laufende Instanz des Portals kann mit dem "webgisdr"-Werkzeug wiederhergestellt werden. Weitere Informationen dazu finden Sie unter Portal for ArcGIS: Wiederherstellen von ArcGIS Enterprise.

Deinstallieren und neu installieren von Portal for ArcGIS

Warnung: Mit den folgenden Anweisungen werden Änderungen an entscheidenden Teilen der ArcGIS Enterprise-Bereitstellung vorgenommen. Esri empfiehlt, vor dem Durchführen der nächsten Schritte eine Sicherung des ArcGIS Enterprise-Computers, einschließlich der Registrierung, zu erstellen. Für die Ergebnisse bei falschen Modifikationen, die mit diesen Anweisungen vorgenommen werden, kann Esri keine Garantie übernehmen. Lassen Sie Vorsicht walten. Wenden Sie sich bei Bedarf an einen Fachmann für Computersysteme.
  1. Führen Sie eine Sicherung des Portal-Inhaltsverzeichnisses durch, und speichern Sie diese in einem temporären Verzeichnis.
  2. Deinstallieren Sie Portal for ArcGIS. Eine Anleitung hierzu finden Sie unter Microsoft: Apps und Programme in Windows 10 deinstallieren oder entfernen.
  3. Installieren Sie die vorherige Version von Portal for ArcGIS erneut. Eine Anleitung hierzu finden Sie unter ArcGIS Enterprise: Installieren von Portal for ArcGIS.
  4. Nachdem die Installation abgeschlossen ist, erstellen Sie die Portal for ArcGIS-Site, indem Sie sie mit dem ursprünglichen Speicherort des Inhaltsverzeichnisses verknüpfen.

Artikel-ID:000026498

Hilfe von ArcGIS-Expert*innen erhalten

Technischen Support kontaktieren

Die Esri Support-App herunterladen

Zu den Download-Optionen

Zugehörige Informationen

Weitere Informationen zu diesem Thema erkunden